Build failure in cubeb_alsa.c when building on Linux with --enable-warnings-as-errors and GCC 4.6

RESOLVED DUPLICATE of bug 1034140

Status

()

RESOLVED DUPLICATE of bug 1034140
4 years ago
4 years ago

People

(Reporter: kats, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8453241 [details]
Build error output

Using my default mozconfig which previously worked fine, I have recently started getting build failures when building m-c. Attached is the relevant error output. It doesn't look like the code changed recently so I'm kind of surprised this started breaking.

gcc --version reports:

gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
Copyright (C) 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1034140
You need to log in before you can comment on or make changes to this bug.