[B2G][2.0][Browser] When the user goes to NBA store, a blank white screen occur

RESOLVED INVALID

Status

Tech Evangelism
Mobile
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Petes, Unassigned, Mentored)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [273MB-Flame-Support] [2.0-exploratory], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8453472 [details]
bb.txt

Description:
When the user goes to NBA shop, a blank white screen occur 

Setup Steps:
1) Flame device is set to 273mb

Repro Steps:
1) Update a Flame device to BuildID: 20140708000322
2) Go to Browser
3) Go to nba.com
4) Tap nba store


Actual:
blank white screen

Expected:
user goes to the store page

Environmental Variables:
Device: Flame 2.0 
Build ID: 20140708000322
Gaia: e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko: 3f9d7a3a0b7b
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8453473 [details]
2014-07-09-17-10-27.png
(Reporter)

Comment 2

4 years ago
This issue also reproduces on the Flame 2.1 (273mb), Buri 2.1, Open C 2.1, Flame 2.0(512mb), Buri 2.0, Open C 2.0, Flame 1.4(273mb), Buri 1.4, and the Open C 1.4. blank white screen

Flame 2.1 (273mb)

Environmental Variables:
Device: Flame Master(273MB)
BuildID: 20140709040203
Gaia: 0f9f11d0a6dadb3ea27160204bbe911c1ad69a6f
Gecko: 196d05832e12
Version: 33.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140709073020
Gaia: c394b7b4205b6f1a6ca44915fc08650f3ad127ec
Gecko: 2d88803a0b9c
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140708040218
Gaia: 740faa5d0060fb218b407cf224330654ddf833a5
Gecko: 465280604ea6
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 2.0(512mb)

Environmental Variables
Device: Flame v2.0 
Build ID: 20140708000322
Gecko: https://hg.mozilla.org/releases/mozilla-aurora/rev/3f9d7a3a0b7b
Gaia: e935f4ff190b76c70d9b2af8856c542a6e4a7546
Platform Version: 32.0a2
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140709063007
Gaia: 1774027323bb072b4ebdfea9883572bcf2535c87
Gecko: 11b6493a7d8f
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140708000322
Gaia: e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko: 3f9d7a3a0b7b
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Flame 1.4(273MB)

Environmental Variables:
Device: Flame 1.4
Build ID: 20140709003002
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140709003002
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140709000201
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Does this happen on 1.3 and the desktop version of Firefox?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(psiphantong)

Updated

4 years ago
Mentor: kdubost@mozilla.com
See Also: → bug 1036772

Comment 4

4 years ago
The Web site experience depends on the geolocation.
In Japan, the users will be redirected to http://www.nba.co.jp/

What is the final domain name. Please put the information in the URL field.
(Reporter)

Comment 5

4 years ago
This issue does not occur on the Buri 1.3, because the browser crashes going to the main site

Environmental Variables:
Device: Buri 1.3
Build ID: 20140709024000
Gaia: 23f55be856cef53c6604a6fe4aeb09061afbc897
Gecko: 601d27e413a9
Version: 28.0 (1.3)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

This issue does not occur desktop version of Firefox, there is no blank white screen
Flags: needinfo?(ktucker)
Please answer Karl's question in Comment 4 and change this issue to the correct product.
Flags: needinfo?(ktucker)
(Reporter)

Comment 7

4 years ago
(In reply to Karl Dubost :karlcow from comment #4)
> The Web site experience depends on the geolocation.
> In Japan, the users will be redirected to http://www.nba.co.jp/
> 
> What is the final domain name. Please put the information in the URL field.

http://store.nba.com/
Component: Mobile → Gaia::Browser
Flags: needinfo?(psiphantong)
Product: Tech Evangelism → Firefox OS
(Reporter)

Updated

4 years ago
Flags: needinfo?(ktucker)
(Reporter)

Updated

4 years ago
Summary: [B2G][2.0][Mobile] When the user goes to NBA store, a blank white screen occur → [B2G][2.0][Browser] When the user goes to NBA store, a blank white screen occur
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 8

4 years ago
Thanks for precising the URL.

I can NOT reproduce, on a Flame device, with 2.0.0.0-prerelease 
Build Identifier: 20140625160200 
Update channel aurora
Platform version 32.0a2

The web site http://store.nba.com/ displays the Desktop content. 
I opened Bug 1036772 for the Web Compat issue. 

I guess there are issues with the current version of the build. I will update today.

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
This is not a gaia browser bug.
Component: Gaia::Browser → Mobile
Product: Firefox OS → Tech Evangelism
So I updated the Flame device.
Model: qcom
B2G: 2.1.0.0-prerelease
buildId: 20140713160201

The Web site displays the Desktop content "as expected" with regards to the Bug 1036772.
There is no blank screen, even after browsing a few pages.

I'm closing this as INVALID. Reopen if you find a specific page triggering white screen. 
Thanks. :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(In reply to Karl Dubost :karlcow from comment #10)
> I'm closing this as INVALID. Reopen if you find a specific page triggering
> white screen. 
> Thanks. :)

When working with reporters, it is often wise to ask the reporter to clarify STR if you can't reproduce the issue. Jumping to close bugs prematurely is bad for quality, as that means you might have left an issue someone found fall through the cracks without asking the right questions to understand the problem. I'm reopening the bug & suggesting that we get more information from the reporter here.
Status: RESOLVED → REOPENED
Flags: needinfo?(psiphantong)
Resolution: INVALID → ---
Hi Jason, reasonable.

"suggesting that we get more information from the reporter here."

Which information are you thinking about?
Flags: needinfo?(jsmith)
(Reporter)

Comment 13

4 years ago
After multiple attempts trying to reproduce this issue on the previous build and the latest one, I was not able to reproduce this issue.
Flags: needinfo?(psiphantong)
Thanks pete! 
Let's close it as INVALID. If it shows up again, a user will reopen it.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID

Updated

4 years ago
Flags: needinfo?(jsmith)
You need to log in before you can comment on or make changes to this bug.