If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SM Trunk: Bustage in mozilla/build/unix/gold

RESOLVED DUPLICATE of bug 1036525

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 1036525
3 years ago
3 years ago

People

(Reporter: Hartmut Figge, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
My build of SM Linux x86_64 failed with

c++  -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Werror=int-to-pointer-cast -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof
 -Wcast-align -fno-strict-aliasing -fno-rtti -fno-math-errno -std=gnu++0x -pthread -pipe -fexceptions  -DNDEBUG -DTRIMMED -Os -freorder-blocks  -fomit-frame-po
inter -fPIC -shared -Wl,-z,defs -Wl,-h, -o test-ctors.so -lpthread  -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id -B /home/hafi/moz-work/src/obj-x86_64-unknown
-linux-gnu/mozilla/build/unix/gold   -Wl,-rpath-link,/home/hafi/moz-work/src/obj-x86_64-unknown-linux-gnu/mozilla/dist/bin -Wl,-rpath-link,/usr/local/lib  test
-ctors.o -nostartfiles
/home/hafi/moz-work/src/obj-x86_64-unknown-linux-gnu/mozilla/build/unix/gold/ld: fatal error: -h: must take a non-empty argument

The bustage is caused by the checkin 5e565152b016 of Bug 1000994. Verified by back out.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036525
You need to log in before you can comment on or make changes to this bug.