Closed Bug 1036810 Opened 6 years ago Closed 6 years ago

[dolphin] MMS can't be sent with Banglalink sim card inside in India .

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: wei.gao, Assigned: bevis)

Details

(Whiteboard: [sprd328660])

Attachments

(3 files)

OS version
---------------------------------------------
FireFoxOS v1.4

Reproduce steps:
---------------------------------------------
Send a MMS using Banglalink sim card in India.

Expected result:
---------------------------------------------
MMS can be sent successfully.

Actual result:
---------------------------------------------
MMS can't be sent with a "Exclamation mark" show.

Probability:
---------------------------------------------
Always Recurrence
Our colleague who is responsible for the modem said that data connection had been connected successfully, could related colleagues in mozilla help to check this issue?

Thanks a great.
Whiteboard: [sprd328660]
Attached file android.zip
This is the log of this issue.

Hi Evelyn

Can you help to transmit this bug to the right owner?
Thanks a great.
Flags: needinfo?(ehung)
Can we have corresponding adb logcat(with mms/ril debuging enabled) & tcpdump for further analysis?
Please follow the link below for how to capture these information:
https://github.com/bevis-tseng/Debug_Tools

Thanks!
Component: Gaia::SMS → RIL
Please see comment 3 for capturing both adb logcat & tcpdump for analysis.

In addition, from the attached log, 
1. The MMS was sent for more about 2 minutes without valid response from network.
2. there is one thing strange about the address of mms proxy:
   It seems to be set to "010.010.055.034".
   Is it a ip-address in Octal which means "8.8.45.28" in Decimal?
   Or shall it be set to "10.10.55.34" instead?
Please help to clarify the APN settings for MMS is correctly set and applied as well.

Thanks!
Assignee: nobody → btseng
NI for comment 3 & comment 4.
Flags: needinfo?(wei.gao)
Flags: needinfo?(ehung)
(In reply to Bevis Tseng [:bevistseng] (btseng@mozilla.com) from comment #4)
> 2. there is one thing strange about the address of mms proxy:
>    It seems to be set to "010.010.055.034".
>    Is it a ip-address in Octal which means "8.8.45.28" in Decimal?
>    Or shall it be set to "10.10.55.34" instead?

Oh, yes, I think that's extremely right. 
I will reset it and let the tester reproduce it in India.

Thanks a great.
Flags: needinfo?(wei.gao)
(In reply to Bevis Tseng (Personal Affairs 7/15~7/22) [:bevistseng] (btseng@mozilla.com) from comment #4)
> 2. there is one thing strange about the address of mms proxy:
>    It seems to be set to "010.010.055.034".
>    Is it a ip-address in Octal which means "8.8.45.28" in Decimal?
>    Or shall it be set to "10.10.55.34" instead?

Dear Bevis

Your guess is perfectly correct.
The rootcause of this issue is the ip-address of apn, when I modified "010.010.055.034" to "10.10.55.34", MMS work fine.
This bug can be closed.
Thank you again, you were so kind.
(In reply to Wei Gao (Spreadtrum) from comment #7)
> (In reply to Bevis Tseng (Personal Affairs 7/15~7/22) [:bevistseng]
> (btseng@mozilla.com) from comment #4)
> > 2. there is one thing strange about the address of mms proxy:
> >    It seems to be set to "010.010.055.034".
> >    Is it a ip-address in Octal which means "8.8.45.28" in Decimal?
> >    Or shall it be set to "10.10.55.34" instead?
> 
> Dear Bevis
> 
> Your guess is perfectly correct.
> The rootcause of this issue is the ip-address of apn, when I modified
> "010.010.055.034" to "10.10.55.34", MMS work fine.
> This bug can be closed.
> Thank you again, you were so kind.

Good to see this clarified. :)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Dear Bevis

There is a new question about failing to send mms.
My india QA tested mms using Banglalink simcard. But the mms failed to be sent high probability.
QA sent 5 times, but only twice were sent successfully, 3 times failed.

I found "Internal server error" in log and a number "129" was returned from network. But I still can't find the rootcause. I have made sure the APN is normal.

I asked QA to resend mms using android reference phone, 5 times were all sent successfully.

Could you give me a hand to analyse this issue?
Thanks a great.
Flags: needinfo?(btseng)
Attached file BL_MMS.zip
This is the log about this issue with pcap file inside.

Could you help to analyse this issue.
Thanks very much.
Hi,

Can we clarify that , in Android, there is no re-transmission for the same failure?
Or it was actually re-transmitted after failure?

Thanks!
Flags: needinfo?(btseng)
(In reply to Wei Gao (Spreadtrum) from comment #9)
> Dear Bevis
> 
> There is a new question about failing to send mms.
> My india QA tested mms using Banglalink simcard. But the mms failed to be
> sent high probability.
> QA sent 5 times, but only twice were sent successfully, 3 times failed.
> 
> I found "Internal server error" in log and a number "129" was returned from
> network. But I still can't find the rootcause. I have made sure the APN is
> normal.
> 
> I asked QA to resend mms using android reference phone, 5 times were all
> sent successfully.
> 
> Could you give me a hand to analyse this issue?
> Thanks a great.

According to OMA MMS standard, error 195(Error-transient-network-problem) X-Mms-Response status in M-Send.conf in Table 28: X-Mms-Response status in M-Send.conf in [1] means 
"
 The MMS Proxy-Relay was not able to handle the corresponding M-Send.req due to unspecified error on 
 the transport layer or capacity overload.
"

And the proposed action by client is 
"to re-transmit unaltered at a later time with the same header fields.
 If this error persists, the MMS Client MAY increase its retransmit interval
"

If we confirm that Android device also met the same error and auto-retried for it, then
what we can do is to add this error to the retry condition check of sending MMS in [2]:
MMS.MMS_PDU_RESPONSE_ERROR_TRANSIENT_NETWORK_PROBLEM == mmsStatus

Where MMS_PDU_RESPONSE_ERROR_TRANSIENT_NETWORK_PROBLEM is equal to 195 defined in [3].

set NI to double confirm if Android device meet the same failure & retry.
If yes, please kindly help to have a trial build with additional retry condition mentioned above to see if the success rate of sending mms in this carrier can be improved.

Thanks!

[1] http://technical.openmobilealliance.org/Technical/release_program/docs/MMS/V1_3-20110913-A/OMA-TS-MMS_ENC-V1_3-20110913-A.pdf
[2] http://mxr.mozilla.org/mozilla-b2g30_v1_4/source/dom/mobilemessage/src/gonk/MmsService.js#1251
[3] http://mxr.mozilla.org/mozilla-b2g30_v1_4/source/dom/mobilemessage/src/gonk/mms_consts.js#55
Flags: needinfo?(wei.gao)
(In reply to Bevis Tseng [:bevistseng] (btseng@mozilla.com) from comment #11)
> Hi,
> 
> Can we clarify that , in Android, there is no re-transmission for the same
> failure?
> Or it was actually re-transmitted after failure?
> 
> Thanks!

Dear Bevis

I have asked our colleague of android, the mms will be resend once send failed whatever the reasons.
But android log QA provided shows that, the mms can be sent once time, and there is no resending log.

I found there was some difference in post request from android and ffos.
Could you help to check is there anything wrong about it?

Thanks.

Android post request
POST http://mmsc1:10021/mmsc/01 HTTP/1.1
Accept: */*, application/vnd.wap.mms-message, application/vnd.wap.sic
x-wap-profile: http://www.google.com/oha/rdf/ua-profile-kila.xml 
Accept-Language: en-US
Content-Length: 28762
Content-Type: application/vnd.wap.mms-message
Host: mmsc1:10021
Connection: Keep-Alive
User-Agent: Android-Mms/0.1
 
 
FirfoxOS post request
POST http://mmsc1:10021/mmsc/01 HTTP/1.1
Host: mmsc1:10021
User-Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Content-Type: application/vnd.wap.mms-message
Content-Length: 33470
Connection: keep-alive
Pragma: no-cache
Cache-Control: no-cache
Flags: needinfo?(wei.gao) → needinfo?(btseng)
Attached file android_log.rar
I don't know whether the android log is helpful to find the cause.

Thanks.
From the android log, our QA sent 8 times mms, all were sent successfully and there was no failure or resending record.

So, maybe we should check it again before modifing the retransmission mechanism.
Thanks so much.
(In reply to Wei Gao (Spreadtrum) from comment #13)
> 
> Dear Bevis
> 
> I have asked our colleague of android, the mms will be resend once send
> failed whatever the reasons.
> But android log QA provided shows that, the mms can be sent once time, and
> there is no resending log.
> 
> I found there was some difference in post request from android and ffos.
> Could you help to check is there anything wrong about it?
> 
> Thanks.

No, I didn't see anything unusual in device side including the HTTP headers.
In addition, according to the error code "195" & the error message "3525: Internal server error" from the M-send.conf, it's more likely to be something wrong in the server side instead.
Flags: needinfo?(btseng)
Dear Bevis

Could you tell me where the "User-Agent" and "Accept" are defined?
I can't find the location.
Thanks so much.

User-Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Flags: needinfo?(btseng)
(In reply to Fabrice Desré [:fabrice] from comment #18)
> The user agent is set at
> http://mxr.mozilla.org/mozilla-central/source/netwerk/protocol/http/
> nsHttpHandler.cpp#590
> 
> The accept header comes from
> http://mxr.mozilla.org/mozilla-central/source/modules/libpref/init/all.
> js#1116

Thank Fabrice very much.
Flags: needinfo?(btseng)
You need to log in before you can comment on or make changes to this bug.