Top Contributors should be removed to avoid fake answers

VERIFIED FIXED in 2014Q3

Status

support.mozilla.org
Army of Awesome
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Emin Mastizada, Assigned: mythmon)

Tracking

(Blocks: 1 bug)

unspecified
2014Q3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=AoA p=1 s=2014.13)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140608211622

Steps to reproduce:

Top Contributors Last Week is working using number of answers by users. Users who answered more tweets are listened in this list, and list is updated everyday


Actual results:

To be in top of this list some users are writing fake spam-like or useless answers to users. Some users already tweeted about that and that they don't liked it. Its bad for Mozilla's reputation.


Expected results:

User must be able to see his own statistics and statistics of other users in their own page. No any top list and etc. So, only users interested in helping others will use this service.

Comment 1

4 years ago
Actually I am also a Army of Awesome (AoA) contributor and I am agree that Top Contributors list should be removed from the site because it motivates competition to be on the top of the list. Some contributors spamming and even replying the tweets without even reading and understanding the issue And some Firefox users also reported about spamming from AoA site.

Comment 2

4 years ago
Created attachment 8453705 [details]
Twitter User's reaction to AoA spamming.

Comment 3

4 years ago
Being also an AoA contributor I couldn't agree more with Emin and Deepanshu. There have been many complaints by Twitter users about spamming and at least one AoA contributor has mis-used the service to harass users of Twitter giving Firefox/Mozilla a bad name.

The attachment AoA5.png is just a specimen of users' reaction on Twitter.

Thanks!
CCing Madalina. This is tough. It looks like we are incentivizing the wrong behavior.
Yes, exactly Ricky.

I believe we should hide this top contributors list and only display it to admins (and moderators, if possible).

Since it would still be useful to know who the most frequent AoA tweeters are. That way in case you need to take action against them, you still can.

Comment 7

4 years ago
Please hide the top contributor's list...and try updating the aoa tweets immediately after they are replied to..since for some of us,we see the tweets as unanswered even if they have been replied to until we refresh or reply
(Reporter)

Comment 8

4 years ago
Created attachment 8455000 [details]
costenslayer-spam.png
(Reporter)

Comment 9

4 years ago
Created attachment 8455001 [details]
sandeep81910240-spamming.png
(Reporter)

Comment 10

4 years ago
Created attachment 8455002 [details]
user-reaction.png

Some of spams and user reactions to them
Attachment #8455000 - Attachment is obsolete: true
Attachment #8455001 - Attachment is obsolete: true
(Reporter)

Updated

4 years ago
Attachment #8455000 - Attachment is obsolete: false
Putting this in sprint 13 as per Michelle and Patrick
Whiteboard: u=contributor c=AoA p= s=2014.13

Updated

4 years ago
Priority: -- → P1
Target Milestone: --- → 2014Q3

Updated

4 years ago
Duplicate of this bug: 1038453

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Remove Top contributor lists from the AoA page.
Summary: Top Contributors Last Week should be removed to avoid fake answers → Top Contributors should be removed to avoid fake answers
pts!
Whiteboard: u=contributor c=AoA p= s=2014.13 → u=contributor c=AoA p=1 s=2014.13
(Assignee)

Comment 15

4 years ago
This is super easy.
Assignee: nobody → mcooper
Status: NEW → ASSIGNED
(Assignee)

Comment 16

4 years ago
PR: https://github.com/mozilla/kitsune/pull/2021
Landed in: https://github.com/mozilla/kitsune/commit/3036c4f29586af663f1e29952dc0194a361ce4fd

Deployed to prod by me just now.

This patch just removes the display of the top contributors. We should probably also remove the backend for this, but that isn't as high a priority. I'm not going to close this bug yet, but I am going to lower the priority.
Priority: P1 → P3
(Reporter)

Comment 17

4 years ago
(In reply to Mike Cooper [:mythmon] from comment #16)
> PR: https://github.com/mozilla/kitsune/pull/2021
> Landed in:
> https://github.com/mozilla/kitsune/commit/
> 3036c4f29586af663f1e29952dc0194a361ce4fd
> 
> Deployed to prod by me just now.
> 
> This patch just removes the display of the top contributors. We should
> probably also remove the backend for this, but that isn't as high a
> priority. I'm not going to close this bug yet, but I am going to lower the
> priority.

I think it will not removed from backend, someone said moderators can need it in feature

Updated

4 years ago
Blocks: 1043431
(Assignee)

Comment 18

4 years ago
Kadir: Should we leave the backend for this in place? Is it going to be used again, or should I remove the dead code?
Flags: needinfo?(a.topal)
Mike, we can leave it for now, since we don't have a final decision on this. It's is not a high priority as you said, I just added this to the tracker bug, because Madalina asked for all AoA bugs created in the last two weeks to be added to it.
Flags: needinfo?(a.topal)
(Assignee)

Comment 20

4 years ago
Ok. I'm going to close this bug out then
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.