bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

wrong autocompletion in compose window with addresses containing comas

RESOLVED DUPLICATE of bug 966053

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 966053
4 years ago
4 years ago

People

(Reporter: klint, Unassigned)

Tracking

({regression})

31 Branch
x86_64
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

I'm using TB 31b2

An email address was retained in the address book as:
Doe, John <john.doe@acme.com>

I type in Doe, then TB displays the full email address in the above format.
And I press Enter to select it (without going in the dropdown list).


Actual results:

2 rows of recipients are inserted:
One with: Doe
One with: John <john.doe@acme.com>


Expected results:

Only one should be inserted:
Doe, John <john.doe@acme.com>
(Reporter)

Comment 1

4 years ago
When the names are separated with a space and no comma, it works well though -since beta 2.

Updated

4 years ago
Blocks: 1008543
Whiteboard: [dupeme]

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 966053
You need to log in before you can comment on or make changes to this bug.