Convert the "Show Update History" dialog on advanced pane to be in-content

VERIFIED FIXED in Firefox 51

Status

()

VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: Paenglab, Assigned: Fischer)

Tracking

unspecified
Firefox 51
Points:
---

Firefox Tracking Flags

(firefox51 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
The "Show Update History" dialog isn't opened through calling the xul file.

I tried it with

showUpdates: function ()
  {
    gSubDialog.open("chrome://mozapps/content/update/history.xul");
  }

The dialog is opened but there is no history shown.

How can the history be loaded into the dialog?

Comment 1

4 years ago
Note that this dialog can also be opened from the troubleshooting page (about:support).
(Assignee)

Comment 2

2 years ago
Created attachment 8775908 [details]
Bug 1037166 - Convert the "Show Update History" dialog on advanced pane to be in-content.

Review commit: https://reviewboard.mozilla.org/r/67940/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/67940/
(Assignee)

Updated

2 years ago
Assignee: nobody → fliu
(Assignee)

Comment 3

2 years ago
Created attachment 8775909 [details]
New_using_gSubDialog.open.png
(Assignee)

Comment 4

2 years ago
Comment on attachment 8775908 [details]
Bug 1037166 - Convert the "Show Update History" dialog on advanced pane to be in-content.

@Jared,
I have moved the "Show Update History" into the in-content sub-dialog. Please see the New_using_gSubDialog.open.png.

However, as we can see inside the New_using_gSubDialog.open.png.
Because of no update histories, it shows nothing but only "No updates installed yet".

I would like to test with histories shown.
Do you know how could we install some fake update histories to test ?

Thank you.
Attachment #8775908 - Flags: feedback?(jaws)
Comment on attachment 8775908 [details]
Bug 1037166 - Convert the "Show Update History" dialog on advanced pane to be in-content.

I built your patch and then opened my newly built binary using my default profile but it also showed "No updates installed yet".

You could write a test that fakes out nsIUpdateManager and returns a list of updates. It would be nice to have an automated test for this dialog anyways. Please let me know if you need some help figuring out a way to replace the updateManager service in your test.
Attachment #8775908 - Flags: feedback?(jaws)
(Assignee)

Comment 6

2 years ago
Created attachment 8776538 [details]
New_using_gSubDialog.open_with_fake_history.png

Using my own profile, I can see the bookmarks changed but cannot see the udpate history either.

However, I found that it is because that the browser built by mach searches for another path. 
In Mac, it searches for /Users/USER_NAME/Library/Caches/Mozilla/updates/Users/USER_NAME/PATH-TO-GECKO-OBJDIR/dist/Nightly.
In Ubuntu: it searches for /home/USER_NAME/PATH-TO-GECKO-OBJDIR/dist/bin

Although not yet found how the searching path is decided, I can successfully load the update history by copying my own update history records to the path above.

See New_using_gSubDialog.open_with_fake_history.png
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 9

2 years ago
Comment on attachment 8775908 [details]
Bug 1037166 - Convert the "Show Update History" dialog on advanced pane to be in-content.

@Jared,

The test is added.
Because the call of promiseLoadSubDialog is needed to check the sub-dialog window loaded, the test is modified to use add_task.

In the test, you can see a mockUpdateManager registered and unregistered for testing purpose.

Please have a look, thank you.
Attachment #8775908 - Flags: review?(jaws)
(Assignee)

Comment 10

2 years ago
@Jared,
BTW, the local test has been passed.
And the try is here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e8bc550bf571
Thanks
(Assignee)

Comment 11

2 years ago
Try again: https://treeherder.mozilla.org/#/jobs?repo=try&revision=2440b32b0d9e&selectedJob=25542514, since there are some tests in Comment 10 which fail during the build stage.
Comment on attachment 8775908 [details]
Bug 1037166 - Convert the "Show Update History" dialog on advanced pane to be in-content.

https://reviewboard.mozilla.org/r/67940/#review69318

Looks good to me. Note that you will need to rebase this patch since bug 1294989 has now landed.
Attachment #8775908 - Flags: review?(jaws) → review+
Comment hidden (mozreview-request)

Comment 15

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6d6f82046da4
Convert the "Show Update History" dialog on advanced pane to be in-content.r=jaws
Keywords: checkin-needed

Comment 16

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6d6f82046da4
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51

Comment 17

2 years ago
I have reproduced this bug with Nightly 33.0a1 (2014-07-10) on Windows 8.1 (64 Bit!).

This bug's fix is verified on Latest Nightly 51.0a1.
Build ID : 20160831030224
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160831]
Thanks!
Status: RESOLVED → VERIFIED
status-firefox51: fixed → verified
You need to log in before you can comment on or make changes to this bug.