[B2G][Marketplace] Youtube app does not launch and prevents the user from leaving the Marketplace when pressing Launch.

RESOLVED DUPLICATE of bug 1037041

Status

Core Graveyard
DOM: Apps
RESOLVED DUPLICATE of bug 1037041
4 years ago
8 months ago

People

(Reporter: Dean R. Gomez (DeanG), Assigned: yifan)

Tracking

({regression})

32 Branch
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 unaffected)

Details

(Whiteboard: [273MB-Flame-Support], [2.0-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8454077 [details]
Logcat_Launch.txt

Description:
When a user launches the Marketplace app, installs the Youtube app, and attempts to launch the Youtube app from within the Marketplace, the user will remain in the Marketplace app without the ability to leave the Marketplace app.

Prerequisites: Be connected to the internet via WiFi.

Repro Steps:
1) Update a Flame to 20140710000201
2) Launch the Marketplace app.
3) In the search field type, 'Youtube' and hit 'Enter' to search.
4) Press 'Install' next to the Youtube app.
5) Once the Youtube app is installed, press the name 'Youtube' next to the launch button.
6) Once on the Youtube information page, press Launch multiple times and press the Home button a few times.

Actual:
The user remains in the Marketplace app and the Home button loses functionality, preventing the user from leaving the Marketplace.
Expected:
The user is taken to the Youtube app and the Home button functions properly, allowing the user to return to the Homescreen when pressed.

2.0 Environmental Variables:
Device: Flame 2.0 (273MB)
BuildID: 20140710000201
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 94714370dfc3
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 3/7
See attached: Logcat_Launch.txt, Video: http://youtu.be/BEGKb5QW9oU
(Reporter)

Comment 1

4 years ago
This issue DOES NOT occur on Flame 2.0 (512MB), Flame 2.1 (273MB), Flame 1.4 (273MB), Buri 2.0, Buri 2.1, Buri 1.4, Open_C 2.0, Open_C 1.4, Open_C 2.1, Flame Base v122 (273MB), and Flame Base v121-2 (273MB).


Flame 2.0 (512mb)

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140710000201
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 94714370dfc3
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 2.1 (273MB)

2.1 Environmental Variables:
Device: Flame Master
Build ID: 20140710040201
Gaia: 4e4e579b4b1e35f863ed43ef6ba840f49bfd761c
Gecko: cb75d6cfb004
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Flame 1.4 (273MB)

1.4 Environmental Variables:
Device: Flame 1.4
Build ID: 20140710000202
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: ccabaf8826a4
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Buri 2.1

2.1 Environmental Variables:
Device: Buri Master
Build ID: 20140710071930
Gaia: 09642e74e250fbc62db860c808ef188628fca55d
Gecko: f93c0ef45597
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.0

2.0 Environmental Variables:
Device: Buri 2.0
Build ID: 20140710000201
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 94714370dfc3
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 1.4

1.4 Environmental Variables:
Device: Buri 1.4
Build ID: 20140710000202
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: ccabaf8826a4
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open_C 2.1

2.1 Environmental Variables:
Device: Open_C Master
Build ID: 20140710071928
Gaia: 09642e74e250fbc62db860c808ef188628fca55d
Gecko: f93c0ef45597
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 2.0

2.0 Environmental Variables:
Device: Open_C 2.0
Build ID: 20140710000201
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 94714370dfc3
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Open_C 1.4

1.4 Environmental Variables:
Device: Open_C 1.4
Build ID: 20140710000202
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: ccabaf8826a4
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Flame Base v122 (273MB)

Base v122 Environmental Variables:
Device: Flame 1.3
Build ID: 20140616171114
Gaia: e1b7152715072d27e0880cdc6b637f82fa42bf4e
Gecko: e181a36ebafaa24e5390db9f597313406edfc794
Version: 28.0 (1.3)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0


Flame Base v121-2 (273MB)

Base v121-2 Environmental Variables:
Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0


Actual Result: The user is taken to the Youtube app and is able to return to the Homescreen via the Home button.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This seems to be a major regression. The user will have to restart their device to regain functionality of their device. Nominating this 2.0? but adding QA Wanted to try and nail down a better repro here.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted

Updated

4 years ago
Component: General → DOM: Apps
Product: Marketplace → Core
Version: Avenir → 32 Branch

Updated

4 years ago
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → unaffected
Simplified STR
1. Launch Marketplace and search "Youtube"
2. Tap Install for Youtube.
3. Tap the Launch button and notice nothing happens.
4. Tap the Home button and notice the user cannot exit the Marketplace app.

Able to repro on:
Environmental Variables:
Device: Flame 2.0
Build ID: 20140710213213
Gaia: 18c44a1bc31b374ba00a069904465a8d07971a60
Gecko: f880dae4fdbe
Version: 32.0a2 (2.0)
Firmware Version: v122
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
FWIW I couldn't just reboot but actually had to pull the battery to get this state fixed.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Contact: croesch

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
QA Contact: jharvey

Comment 5

4 years ago
Yi-Fan, can you help to take a look on this bug? Thanks.
Flags: needinfo?(yliao)
(Assignee)

Updated

4 years ago
Assignee: nobody → yliao
Flags: needinfo?(yliao)
(Assignee)

Comment 6

4 years ago
Tested with latest Gaia with 273MB, Facebook and Line failed, either. Luke helped finding that Market Place and Homescreen were both active when the phone was hanged.

Gaia      2c0fcd287a9536d1c9acde18f87d9d454b554c14
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/94714370dfc3
BuildID   20140710000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

Comment 7

4 years ago
Interesting, thanks! So, what's the next step? To isolate the root causes? Or, we already know what to do next. Thanks.
(Assignee)

Comment 8

4 years ago
We have a couple bugs that share the same symptom and are tracing the root cause. Will update ASAP once we sort it out.
(Assignee)

Comment 9

4 years ago
The root cause of this bug is mostly due to the termination of homescreen app.
Step by step explanation:

1. Open MarketPlace, install Youtube (or Facebook, Line, etc...):
   mozbrowsererror event will be fired and Homescreen will be terminated here.
   In the system app, the DOM element of Homescreen is removed, but its instance reference is still kept by app_window_manager and homescreen_launcher.

2. Launch Youtube in MarketPlace:
   In the system app, 'switchApp' method is called with 'switching' parameter is true. On line 159:

>        if (switching) {
>          homescreenLauncher.getHomescreen().fadeOut();
>        }
   
   homescreenLauncher will return the homescreen instance without knowing that the DOM element of it has been removed. It results in the exception 'this.element is null' in the fadeOut() call.

-------------------

One quick fix is:
>          homescreenLauncher.getHomescreen(true).fadeOut();
This ensures that the homescreen DOM element exists.

Another possible error is that the 'switching' parameter passed in is mistaken. Here's the description:
>    * @param  {Boolean} [switching] Homescreen doesn't involve in the two apps.

and here is the value of this bug:
>    var switching = appCurrent && !appCurrent.isHomescreen && !appNext.isHomescreen;
I am sure if the 'switching' value should be false or not. Any ideas?
Flags: needinfo?(alive)
(In reply to Yi-Fan Liao [:yifan][:yliao] from comment #9)
> The root cause of this bug is mostly due to the termination of homescreen
> app.
> Step by step explanation:
> 
> 1. Open MarketPlace, install Youtube (or Facebook, Line, etc...):
>    mozbrowsererror event will be fired and Homescreen will be terminated
> here.
>    In the system app, the DOM element of Homescreen is removed, but its
> instance reference is still kept by app_window_manager and
> homescreen_launcher.

https://bugzilla.mozilla.org/show_bug.cgi?id=1037041 should fix it.

> 
> 2. Launch Youtube in MarketPlace:
>    In the system app, 'switchApp' method is called with 'switching'
> parameter is true. On line 159:
> 
> >        if (switching) {
> >          homescreenLauncher.getHomescreen().fadeOut();
> >        }
>    
>    homescreenLauncher will return the homescreen instance without knowing
> that the DOM element of it has been removed. It results in the exception
> 'this.element is null' in the fadeOut() call.
> 
> -------------------
> 
> One quick fix is:
> >          homescreenLauncher.getHomescreen(true).fadeOut();
> This ensures that the homescreen DOM element exists.
> 
> Another possible error is that the 'switching' parameter passed in is
> mistaken. Here's the description:
> >    * @param  {Boolean} [switching] Homescreen doesn't involve in the two apps.
> 
> and here is the value of this bug:
> >    var switching = appCurrent && !appCurrent.isHomescreen && !appNext.isHomescreen;
> I am sure if the 'switching' value should be false or not. Any ideas?

What's the problem here? I don't understand what you are sure. Please elaborate.
Flags: needinfo?(alive)
(Assignee)

Comment 11

4 years ago
Thank you. I was unsure where to code the fix, we could drop it since it's fixed with that patch.
(Assignee)

Updated

4 years ago
See Also: → bug 1037041

Comment 12

4 years ago
B2G Inbound


Last Working

Environmental Variables:
Device: Flame Master
Build ID: 20140604084216
Gaia: 2a4c7becdb141d2601e47a040a27eebe52a8db79
Gecko: fd5bb34861d6
Version: 32.0a1 (Master)
Firmware Version: v122


First Broken

Environmental Variables:
Device: Flame Master
Build ID: 20140604105916
Gaia: 18e2e8dc2d9ff19cd1210026367c14956d04eb0d
Gecko: c36c5f011229
Version: 32.0a1 (Master)
Firmware Version: v122


Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 2a4c7becdb141d2601e47a040a27eebe52a8db79
Gecko: c36c5f011229


First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 18e2e8dc2d9ff19cd1210026367c14956d04eb0d
Gecko: fd5bb34861d6


Gaia Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/2a4c7becdb141d2601e47a040a27eebe52a8db79...18e2e8dc2d9ff19cd1210026367c14956d04eb0d
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
another regression-window indicating the vertical home-screen split
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kgrandon)
(Assignee)

Comment 14

4 years ago
Should've been fixed on Gaia 363e32deb090554ec27a4164f5c5a5b941b9037b
Flags: needinfo?(dgomez)
(Assignee)

Comment 15

4 years ago
Sorry for the grammar mistake, it's fixed on Gaia 363e32deb090554ec27a4164f5c5a5b941b9037b
It seems like bug 1037041 will fix this? Not really sure what I can add here.
Flags: needinfo?(kgrandon)
(Assignee)

Comment 17

4 years ago
This bug was fixed in COMMIT 18c9d890a81768109c9d85fe49fe80d3935a0917
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

4 years ago
Depends on: 1037041
(Assignee)

Updated

4 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1037041
(Reporter)

Updated

4 years ago
Flags: needinfo?(dgomez)

Updated

8 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.