[B2G][Flame][Music] Music will stop playing when opening and closing other apps

RESOLVED INVALID

Status

Firefox OS
Gaia::Music
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [273MB-Flame-Support][2.0-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8454160 [details]
logcat.txt

Description:
While listening to music and using other apps the music will stop playing sometimes.

Repro Steps:
1) Update a Flame device to BuildID: 20140710000201
2) Set Phone memory to 273mb
3) Open music app
4) Start playing a song
5) Open marketplace
6) wait for marketplace to load
7) Press home button
8) Open games smart collection
9) Press Home button
10) Wait for smart collection to load
11) Observe music stop playing between steps 5-10

Actual:
Music will stop playing while using other apps

Expected:
it is expected that the music continues playing while using other non media apps

Environmental Variables:
Device: Flame v2.0 (273mb)
Build ID: 20140710000201
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 94714370dfc3
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Keywords: Low memory kill, crash, lmk


Notes:
This issue occurs many different ways but this is the most solid repro steps I could find

Repro frequency: 90%
See attached: video clip(http://youtu.be/mQM67CgN_dg), logcat

--------------------------------------------------

This issue also occurs on Flame 2.1 (273mb), Flame Base v121-2.

Environmental Variables:
Device: Flame Master(273mb)
Build ID: 20140710040201
Gaia: 4e4e579b4b1e35f863ed43ef6ba840f49bfd761c
Gecko: cb75d6cfb004
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

Actual:
Music will stop playing while using other apps

--------------------------------------------------

This issue does not occur on Flame 2.0 (512mb), Flame 1.4, Buri 1.4, Buri 2.0, Buri 2.1, Open_C 1.4, Open_C 2.0, Open_C 2.1, Flame Base v122.


Environmental Variables:
Device: Flame v2.0 (512mb)
Build ID: 20140710000201
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 94714370dfc3
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame 1.4
Build ID: 20140710000202
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: ccabaf8826a4
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Flame 1.3
Build ID: 20140616171114
Gaia: e1b7152715072d27e0880cdc6b637f82fa42bf4e
Gecko: e181a36ebafaa24e5390db9f597313406edfc794
Version: 28.0 (1.3)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

Environmental Variables:
Device: Buri Master
Build ID: 20140710071930
Gaia: 09642e74e250fbc62db860c808ef188628fca55d
Gecko: f93c0ef45597
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140710000201
Gaia: 35a9b715e7348ec738ff6c8a59f50190390a06f2
Gecko: 94714370dfc3
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Buri 1.4
Build ID: 20140710000202
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: ccabaf8826a4
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Open_C Master
Build ID: 20140708040218
Gaia: 740faa5d0060fb218b407cf224330654ddf833a5
Gecko: 465280604ea6
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140708000322
Gaia: e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko: 3f9d7a3a0b7b
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140709000201
Gaia: b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko: acf704e54e19
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Actual:
Music continues playing while using other apps
(Reporter)

Updated

3 years ago
Keywords: regression
Whiteboard: [273MB-Flame-Support][2.0-exploratory]
Status: UNCONFIRMED → NEW
QA Whiteboard: [QAnalyst-Triage?]
Ever confirmed: true
Flags: needinfo?(ktucker)
Bug 1037154 or Bug 1037360 might be related to this.
This is a regression from 1.4. Nominating this 2.0? since this issue would affect a large number of end users.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(aalldredge)
Keywords: regressionwindow-wanted
Please attach a new video minus all the background audio.
Unable to find a regression window due to bug occurs on earliest tinderbox Flame central build ID 20140417000006.
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA-Wanted report: Regression window unavailable as per comment 4; can not attempt a Buri window as the bug is Flame only. 
 Leaving triage tag alone as it has been flipped to - to get additional work from the bug reporter.
Flags: needinfo?(jmitchell)
Blocking- This is an unwanted but not unexpected scenario in low memory conditions on Flame. (LMK is likely doing what it is supposed to do.) This is likely part of a larger systemic issue with low memory on Flame that should be addressed separately. The workaround is of course to relaunch the music app.
blocking-b2g: 2.0? → -
(Reporter)

Updated

3 years ago
Flags: needinfo?(aalldredge)
(Reporter)

Comment 7

3 years ago
Uploaded a new video - http://youtu.be/lto2cMHY0KI
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to KTucker (:KTucker) from comment #2)
> This is a regression from 1.4. Nominating this 2.0? since this issue would
> affect a large number of end users.

Actually double checking the branch analysis, I think the reporter indicated that this was reproducing on the 1.3 base image, so I think this isn't a regression.
Keywords: regression

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Closing since we are now running Flame at the 512MB configuration for v2.5
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Flags: needinfo?(wmathanaraj)
Wilfred, is this the correct statement?  Have we decided this officially?  Or are we still investigating.
If we're still investigating whether or not 2.5 should be on 512, please reopen this bug.
512 is the decision we already did on the drivers meeting.
Flags: needinfo?(wmathanaraj)
You need to log in before you can comment on or make changes to this bug.