Closed Bug 1037285 Opened 5 years ago Closed 5 years ago

Login redirection from forms is broken for urls using a : in their url

Categories

(Bugzilla :: Bugzilla-General, defect, P2, minor)

Tracking

()

RESOLVED FIXED
Bugzilla 5.0

People

(Reporter: dylan, Assigned: dylan)

Details

Attachments

(1 file)

It seems that if you are not logged into BMO and you navigate to a form (for instance, https://bugzilla.mozilla.org/form:automative ) you will not we able to login. Viewing the source shows that the form action is redirected to "form:automative".
Blocks: 1028269
The small login form prepends [% urlbase %] to the form action for logins, but the full-sized login form does not. This patch changes the big login form and fixes this bug.
Attachment #8455047 - Flags: review?(dkl)
Status: NEW → ASSIGNED
No longer blocks: 1028269
Severity: normal → minor
Component: General → Bugzilla-General
Product: bugzilla.mozilla.org → Bugzilla
QA Contact: default-qa
Summary: Login redirection from forms is broken → Login redirection from forms is broken for urls using a : in their url
Version: Production → unspecified
Attachment #8455047 - Flags: review?(dkl) → review?(glob)
Priority: -- → P2
Comment on attachment 8455047 [details] [diff] [review]
bug-1037285-v1.patch

Review of attachment 8455047 [details] [diff] [review]:
-----------------------------------------------------------------

r=glob
Attachment #8455047 - Flags: review?(glob) → review+
Flags: approval+
Target Milestone: --- → Bugzilla 5.0
To gitolite3@git.mozilla.org:bugzilla/bugzilla.git
   28bcce5..ffec347  master -> master
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.