Intermittent browser_projecteditor_menubar_01.js | [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.create]" nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" location: "JS frame :: resource://gre/modu

RESOLVED FIXED in Firefox 33

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: RyanVM, Assigned: bgrins)

Tracking

({intermittent-failure})

Trunk
Firefox 34
x86
Windows 7
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox32 unaffected, firefox33 fixed, firefox34 fixed, firefox-esr24 unaffected, firefox-esr31 unaffected)

Details

Attachments

(2 attachments, 1 obsolete attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=43560448&tree=Mozilla-Inbound

Windows 7 32-bit mozilla-inbound debug test mochitest-devtools-chrome-2 on 2014-07-10 16:40:12 PDT for push e1a037c085d1
slave: t-w732-ix-096

16:59:53     INFO -  TEST-START | chrome://mochitests/content/browser/browser/devtools/projecteditor/test/browser_projecteditor_menubar_01.js
16:59:53     INFO -  [1416] WARNING: NS_ENSURE_SUCCESS(EnsureScriptEnvironment(), nullptr) failed with result 0x80040111: file c:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/docshell/base/nsDocShell.cpp, line 4142
16:59:53  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/projecteditor/test/browser_projecteditor_menubar_01.js | [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.create]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: resource://gre/modules/FileUtils.jsm :: FileUtils_getDir :: line 70"  data: no]
16:59:53     INFO -  Stack trace:
16:59:53     INFO -  resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:Handler.prototype.process:869
16:59:53     INFO -  resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:this.PromiseWalker.walkerLoop:745
16:59:53     INFO -  null:null:0
16:59:53     INFO -  [1416] WARNING: NS_ENSURE_TRUE(window) failed: file c:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\dom\base\Console.cpp, line 328
16:59:53     INFO -  TEST-INFO | MEMORY STAT vsize after test: 1317724160
16:59:53     INFO -  TEST-INFO | MEMORY STAT vsizeMaxContiguous after test: 385417216
16:59:53     INFO -  TEST-INFO | MEMORY STAT residentFast after test: 654336000
16:59:53     INFO -  TEST-INFO | MEMORY STAT heapAllocated after test: 195214098
16:59:53     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/projecteditor/test/browser_projecteditor_menubar_01.js | finished in 359ms
So, is it not safe to create and modify temporary files during tests?  There are a couple of related intermittents where the cause is either creating or deleting a file for the test, including Bug 1024994 and Bug 1026972.  Luckily they all seem quite uncommon.
I couldn't think of any good way to prevent this error from happening (the test server just intermittently is unable to write to its temp directory).  As discussed, here is an attempt in which it will just try again if it doesn't work.  I have no idea if this will fix the issue as I can't reproduce it, but here is a try push: https://tbpl.mozilla.org/?tree=Try&rev=73d93f969096.
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8464761 - Flags: review?(jwalker)
Attachment #8464761 - Flags: review?(jwalker) → review+
Hrm, looks like trying a second time isn't solving all cases (like https://tbpl.mozilla.org/php/getParsedLog.php?id=45104197&tree=Fx-Team#error0 - I see "Project Editor temp directory creation failed.  Trying again." right before the failure).  It may be causing less errors, but it definitely isn't fixing it entirely.  I guess we could try wrapping the second call in a timeout and see if that helps.
https://hg.mozilla.org/mozilla-central/rev/b719ea75d223
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attempting to use a unique directory name for each test to see if that prevents the errors
Attachment #8467089 - Flags: review?(jwalker)
Attachment #8467089 - Flags: review?(jwalker) → review+
Fixes typo in commit message
Attachment #8467089 - Attachment is obsolete: true
Attachment #8467096 - Flags: review+
QA Whiteboard: [qa-]
https://hg.mozilla.org/integration/fx-team/rev/4c5cc54c20bf
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Attachment #8467096 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/4c5cc54c20bf
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.