Need an attribute for add-ons to override max/min height set due to toolbar animations

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: optical.mahir, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Posted image snapshot2.png
User Agent: Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140709030201

Steps to reproduce:

1. I installed HackBar in Nightly 33
2. Restarted My browser.
3. From View>Toolbar, I checked HackBar



Actual results:

No, HackBar Toolbar was added to my window. Repeated the steps 5 times, but same result hit me. 


Expected results:

It should have added the HackBar toolbar under the "Awesome Bar".

Comment 1

5 years ago
This is essentially an issue in the add-on, as far as I can tell. You should contact the authors of the add-on about it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
Duplicate of this bug: 1045049

Comment 3

5 years ago
Hi,

I am one of the developers of the extension. I created the issue 1045049 (https://bugzilla.mozilla.org/show_bug.cgi?id=1045049) without realising this one was created.

The extension has worked correctly for the past few years, since Firefox 3 and it is only on latest version that Firefox has break the expected behaviour of the application.

I have check on the Addons blog looking on the changelog but I couldn't find any reference to changes that might justify this.

My humble opinion is that something has change in Firefox not to allow toolbars bigger than 40-50 px and that is breaking the extension. Users should have the opportunity to have bigger toolbars.

Comment 4

5 years ago
(In reply to plaguna from comment #3)
> Hi,
> 
> I am one of the developers of the extension. I created the issue 1045049
> (https://bugzilla.mozilla.org/show_bug.cgi?id=1045049) without realising
> this one was created.
> 
> The extension has worked correctly for the past few years, since Firefox 3
> and it is only on latest version that Firefox has break the expected
> behaviour of the application.
> 
> I have check on the Addons blog looking on the changelog but I couldn't find
> any reference to changes that might justify this.
> 
> My humble opinion is that something has change in Firefox not to allow
> toolbars bigger than 40-50 px and that is breaking the extension. Users
> should have the opportunity to have bigger toolbars.

You can alter the max-height property to a more suitable value to fix. The idea is that toolbars transition in/out now, and so we transition the max/min-height properties - we didn't think that 4em would be a problem for anyone. I doubt that we'd want to increase it, although I suppose we could. Dão?
Blocks: 867317
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(dao)
Resolution: INVALID → ---
(In reply to :Gijs Kruitbosch (Bugmail catchup, needinfo if urgent) from comment #4)
> I doubt that we'd want to increase it, although I suppose we could. Dão?

Not to a value big enough to satisfy HackBar, no.

We could support an attribute that add-ons could set to skip the animation.
Flags: needinfo?(dao)

Comment 6

5 years ago
Hi, i'm also one of the developers. A value to skip the animation would be an excellent solution imo.

Is it an option to remove the {overflow:hidden} behaviour after the animation is finished? I know it would create a weird jump, but at least the functionality of the add-on would not be compromised.

This would also fix problems with other, smaller toolbars that have the ability to resize (Like hackbar)

Comment 7

5 years ago
Is there an attribute implemented in v33 to skip the animation? Or any other solution that enables toolbars to be higher than 40-50px?
(In reply to Johan Adriaans from comment #7)
> Is there an attribute implemented in v33 to skip the animation?

No, nobody worked on this bug. Patches welcome!

> Or any other solution that enables toolbars to be higher than 40-50px?

You can override the CSS for your toolbar as mentioned in comment 4.

Comment 9

5 years ago
Ah, great. Sorry, I missed that bit. Will fix it asap. Might have a look at a patch as well.

Tnx!

Updated

5 years ago
Summary: on Linux 32-bit Nightly 33 not showing toolbar properly → Need an attribute for add-ons to override max/min height set due to toolbar animations

Comment 10

5 years ago
Hi,
I had the same problem with the FF33 that the HackBar was not displayed correctly, 
my solution

Create the useeCHrome.css file in the following folder if does not exist
%APPDATA%\Mozilla\Firefox\Profiles\<Profilordner>\chrome\
(Sorry German Windows Sytsem)

Add the following lines to the userChrome.css

/*Toobar height*/
toolbar {max-height:270px !important;}
#toolbar-menubar {padding: 0px !important;}


Save and restart Firefox. This has helped me. 
Hope you have success with it :)

Updated

5 years ago
Duplicate of this bug: 1083929

Comment 12

5 years ago
For anyone that is interested. I have just fixed the bug in HackBar version 1.6.3 and it is waiting to be reviewed.

Cheers!
Hello Reporter, thank you for reporting this issue. As Johan mentioned, it seems that your issue has been fixed with Hackbar version 1.6.3. I tried to duplicate your issue on Linux 32 bit and Windows 10 64 bit using the latest Nightly and Released Firefox versions respectively with Hackbar version 1.6.3.1 installed but could not duplicate it. 

Name 	Firefox
Version 	46.0a1
Build ID 	20160110030214
Update Channel 	nightly
User Agent 	Mozilla/5.0 (X11; Linux i686; rv:46.0) Gecko/20100101 Firefox/46.0

Name 	Firefox
Version 	43.0.4
Build ID 	20160105164030
Update Channel 	release
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

If you have not upgraded your Firefox and Hackbar to their latest versions, may I please request you to do that and try again.

I'll close this defect as "Resolved - Fixed" after your confirmation.
Component: Untriaged → General
Flags: needinfo?(optical.mahir)
Product: Firefox → Toolkit

Comment 14

3 years ago
This is fixed by the add-on for comment #0, but the current summary of the bug is an issue that could be fixed in Firefox if someone wrote a patch. It's Firefox-CSS-specific, so it shouldn't be in toolkit.
Component: General → Theme
Flags: needinfo?(optical.mahir)
OS: Linux → All
Product: Toolkit → Firefox
Hardware: x86 → All
Version: 33 Branch → Trunk
Issue is fixed and not reproducible for me. Changing status to Resolved-Incomplete due to time since last communication/update by reporter.
Please feel free to reopen if the error occurs in a current Firefox version.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago3 years ago
Resolution: --- → INCOMPLETE

Comment 16

3 years ago
(In reply to Kanchan Kumari QA from comment #15)
> Issue is fixed and not reproducible for me. Changing status to
> Resolved-Incomplete due to time since last communication/update by reporter.
> Please feel free to reopen if the error occurs in a current Firefox version.

When closing a bug, please read its comments. In this case, please see comment #14.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
(In reply to :Gijs Kruitbosch from comment #16)
> (In reply to Kanchan Kumari QA from comment #15)
> > Issue is fixed and not reproducible for me. Changing status to
> > Resolved-Incomplete due to time since last communication/update by reporter.
> > Please feel free to reopen if the error occurs in a current Firefox version.
> 
> When closing a bug, please read its comments. In this case, please see
> comment #14.

My bad...I completely missed comment #14. I was focusing on just the original problem that the reporter reported. Thanks for correcting me and reopening this issue!

Comment 18

a year ago
Support for legacy add-ons has been removed, so this is no longer needed.
Status: REOPENED → RESOLVED
Last Resolved: 3 years agoa year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.