Removing a blockquote using outdent button causes the caret to jump to previous line

VERIFIED WORKSFORME

Status

()

Core
Editor
P1
normal
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: TucsonTester2, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE; 1 day?)

(Reporter)

Description

17 years ago
Build ID: 20011004

Outdenting lines with no text causes the cursor to jump to the line above.

Reproducible: Always

Steps to Reproduce:
1.Open Composer
2.Click on the indent button on the toolbar
3.Type some text and hit enter
4.Click on the outdent button

Actual Results:
The cursor jumps to the line above.  If you click on the line where the cursor
used to be you will see that it is outdented.

Expected Results:
What should happen instead is that the cursor should remain on it's own line but
not have an indent.

Comment 1

17 years ago
confirming
Assignee: syd → cmanske
Whiteboard: EDITORBASE

Comment 2

17 years ago
editor core
Assignee: cmanske → jfrancis
Component: Editor: Composer → Editor: Core
Assisting syd with a real confirm to get it on radar.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011113
bug is still present.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

17 years ago
I need to work on outdent for 098 anyway...
Status: NEW → ASSIGNED
Whiteboard: EDITORBASE → EDITORBASE; 1 day?
Target Milestone: --- → mozilla0.9.8

Updated

17 years ago
Summary: Removing a blockquote using outdent button causes the cursor to jump to previous line → Removing a blockquote using outdent button causes the caret to jump to previous line

Comment 5

17 years ago
And if you hit enter, you get a blank line instead of being place on the next
line. Woowee!
Priority: -- → P1

Comment 6

17 years ago
works for me mac osx build 2001121805...

Comment 7

17 years ago
Works for me also on Win 2k using build 2001122103.

I am resolving as WORKSFORME.

If anyone is still seeing this problem, please reopen.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.