Status

()

Firefox for Android
General
REOPENED
4 years ago
2 years ago

People

(Reporter: Pawel, Unassigned)

Tracking

30 Branch
Other
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Click on link at google or bing result search page. 
Firefox 30 on Nexus 4 Android 4.4.4. In about:config flag layout.css.visited_links_enabled is set to default value - true.


Actual results:

Link color remains blue.


Expected results:

Link color should change to visited - purple (#551A8B).
(Reporter)

Updated

4 years ago
Component: Untriaged → General
OS: Windows 7 → Android
Product: Firefox → Firefox for Android
Hardware: x86_64 → Other
Version: 30 Branch → Firefox 30

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 981078
reopen based on bug 981078 Comment #7
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 3

4 years ago
981078 says 1037414 is a duplicate of that.
1037414 says 981078 is a duplicate of this.
A classic deadlock.

Firefox on a Samsung SM-T320 Android occasionally marks a visited link with a pale blue color but usually doesn't. 

I have tried unsuccessfully to find a sequence of steps that will guarantee a visited link is marked properly as visited.

I would appreciate it very much if someone is able to look into this, 

Thank you.
In order to decide if a link was visited previously, Firefox will load the entire saved URL history into a HashMap, iirc. If that fails to load, or the history has been removed, the link will not appear "visited".

Comment 5

2 years ago
Hi,I want to work on this.I have built Fennec.Could someone guide me to the location of the code where the visited links are checked?
Thanks
You need to log in before you can comment on or make changes to this bug.