Fails to build in debug mode with disabled JIT

RESOLVED FIXED in mozilla33

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

Trunk
mozilla33
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Js engine fails to build in debug mode with disabled ION.
Posted patch patchSplinter Review
Igor, can you check this one? Thanks!
Attachment #8454466 - Flags: review?(igor)
No, this one is different - fails only in the Debugger.cpp and it's caused by #ifdef JS_ION in RematerializedFrame.h.

RematerializedFrame class is not defined when ion is disabled but it's still used in the debugger.
Comment on attachment 8454466 [details] [diff] [review]
patch

Review of attachment 8454466 [details] [diff] [review]:
-----------------------------------------------------------------

Igor left the project years ago so I'll r+ this patch.
Attachment #8454466 - Flags: review?(igor) → review+
(Just for future reference, a full "-b do -p all -u all" Try build for a trivial patch that should have no effect on our official builds is usually frowned upon. During the weekend it's less of an issue, but on other days there can be significant backlog/delays on Try.)
Okay, thanks.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/46229cdd48f4
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.