Implementation of new 'mark as read/unread' icons in email app

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::E-Mail
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: rishav_, Assigned: jrburke)

Tracking

unspecified
2.1 S3 (29aug)

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.2 verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140608211622

Steps to reproduce:

New icons for mark as read/unread is introduced in Bug 1022066 https://bugzilla.mozilla.org/show_bug.cgi?id=1022066
In this bug those icons should be implemented in email app
(Reporter)

Comment 1

4 years ago
Created attachment 8454673 [details]
icon_email_read_unread.zip

Mark as Unread/Read icons
https://bugzilla.mozilla.org/attachment.cgi?id=8448594

Comment 2

4 years ago
Created attachment 8457810 [details]
Email_icon_MarkAs_Unread_unread.zip

Hi,
Attached is the redesign of Mark as Unread/Read icons. Thanks!
(Reporter)

Comment 3

4 years ago
Hi jrburke
As new icons has arrived for email app too, are you working on this? 
Thanks
Flags: needinfo?(jrburke)
(Assignee)

Comment 4

4 years ago
Thanks for the reminder, I should be able to pick this up in this coming sprint.
Assignee: nobody → jrburke
Flags: needinfo?(jrburke)
Target Milestone: --- → 2.1 S3 (29aug)
(Assignee)

Comment 5

4 years ago
Created attachment 8474843 [details]
email-read-unread.png

Asking for UX review for the initial code branch that can be found here:

https://github.com/jrburke/gaia/compare/bug1037635-email-read-icons

The attached image shows the different states with the new icons in place. Guide for 4 images in this attachment:

1) First entering bulk edit, no messages selected. Buttons are greyed out/disabled and default image is to show the "mark as read" icon.

2) One unread message selected. Edit buttons now enabled, and mark button is showing "mark as read" icon.

3) One read message selected. Mark button is showing "mark as unread" icon.

4) One read message and one uread message selected. Mark button shows "mark as unread" icon.
Attachment #8474843 - Flags: ui-review?(jhuang)

Comment 6

4 years ago
Comment on attachment 8474843 [details]
email-read-unread.png

Awesome! I also check icons with Fang and it's no problem.
Thanks James :)
Attachment #8474843 - Flags: ui-review?(jhuang) → ui-review+
(Assignee)

Comment 7

4 years ago
Created attachment 8474982 [details] [review]
GitHub pull request

UX approved, so proceeding with technical review. :asuth, if you prefer some review space, give a holler and I will redirect. If it helps, visual inspection should be enough, see screen captures, notes in pull request.
Attachment #8474982 - Flags: review?(bugmail)
Comment on attachment 8474982 [details] [review]
GitHub pull request

r=asuth by inspection.  Tiny reviews are a welcome break from integration test stuff!
Attachment #8474982 - Flags: review?(bugmail) → review+
(Assignee)

Comment 9

4 years ago
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/1a181001aafe7cc56c8b4fd9909f501c086d9572

from pull request:
https://github.com/mozilla-b2g/gaia/pull/23020
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
[Enviroment]
Gaia      e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko     https://hg.mozilla.org/mozilla-central/rev/daa84204a11a
BuildID   20140824160205
Version   34.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

[Result]
PASS
Status: RESOLVED → VERIFIED
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → fixed

Comment 11

3 years ago
Created attachment 8530014 [details]
Verify_video.3gp

This issue has been verified successfully on Flame 2.1,2.2

See attachment: Verify_video.3gp
Reproducing rate: 0/5
Flame2.1 build:
Gaia-Rev        5372b675e018b6aac97d95ff5db8d4bd16addb9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f34377ae402b
Build-ID        20141127001201
Version         34.0

FLame 2.2 build:
Gaia-Rev        80bc1445959db79e9d2e947cc56e1eb7b0d3d0f0
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/7dfad34d265b
Build-ID        20141127040204
Version         36.0a1

Updated

3 years ago
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified

Updated

3 years ago
Duplicate of this bug: 1098216
You need to log in before you can comment on or make changes to this bug.