KeyUp, KeyDown, and KeyPress events do not register on Japanese keyboards

RESOLVED DUPLICATE of bug 354358

Status

()

RESOLVED DUPLICATE of bug 354358
5 years ago
5 years ago

People

(Reporter: joshchurch29, Unassigned)

Tracking

30 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

1: Change keyboard layout to Katakana or Hiragana
2: Set listener for keyUp, keyDown, or keyPress events


Actual results:

Events do not register until the enter key is pressed.


Expected results:

Events should register per key press.
Component: JavaScript Engine → DOM: Events
Could you attach a minimum testcase?
Flags: needinfo?(joshchurch29)
(Reporter)

Comment 2

5 years ago
Switch your keyboard Katakana or Hiragana, try the interactive demo here, http://www.willmaster.com/library/tutorials/onkeydown-onkeyup-onclick-and-onchange-javascript-events.php
Flags: needinfo?(joshchurch29)
Ah, I see what you say, probably. This must be a dup of bug 354358.

FYI: keydown/keyup events are fired on other browsers even during using IME. However, it would be INVALID in DOM Level 3 Events definition.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 354358
You need to log in before you can comment on or make changes to this bug.