bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[B2G][Settings][Firefox Account] "Marketplace" and "Find My Device" within Firefox Accounts page are not functional buttons

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Jordan de Geus(JordanD), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [273MB-Flame-Support], [2.0-exploratory])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8454803 [details]
Button.png

Description:
When users sign into a Firefox Account, upon viewing the Firefox Accounts page within Settings, users will see "Marketplace" and "Find My Device" however they are not functional buttons. 

Repro Steps:
1) Update a Flame device to BuildID: 20140708000322
2) Set Flame to 273mb and reboot device
3) Navigate to Settings> Firefox Accounts> Log into an account
4) Observe under "Signed In", "Marketplace" and "Find My Device" are not functional buttons

Actual:
"Marketplace" and "Find My Device" within Firefox Accounts page are not functional buttons
Expected:
"Marketplace" and "Find My Device" are functional buttons

Environmental Variables:
Device: Flame 2.0 (273mb)
BuildID: 20140711000201
Gaia: 18c44a1bc31b374ba00a069904465a8d07971a60
Gecko: f880dae4fdbe
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 5/5
See attached: Logcat and Screenshot attached
Logcat_Firefox.txt - Button.png
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.1 (273mb), Flame 2.0 (512mb), Buri 2.1, Buri 2.0

Flame 2.1 (273mb)

Environmental Variables:
Device: Flame Master
Build ID: 20140711040202
Gaia: c47094a26c87ba71a3da4bae54febd0da21f3393
Gecko: 1b1296d00330
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 2.0 (512mb)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140711000201
Gaia: 18c44a1bc31b374ba00a069904465a8d07971a60
Gecko: f880dae4fdbe
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140711040202
Gaia: c47094a26c87ba71a3da4bae54febd0da21f3393
Gecko: 1b1296d00330
Version: 33.0a1 (Master) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140711000201
Gaia: 18c44a1bc31b374ba00a069904465a8d07971a60
Gecko: f880dae4fdbe
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Actual: After signing into Firefox Account, users are return to the Firefox Accounts page which contains "Marketplace" and "Find My Device". These two strings are only text and lack any button functionality.

---------------------------------------------------------------------------------

I am unable to test this issue as Firefox Accounts page within Settings is not present on 1.4.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Updated

4 years ago
Summary: [B2G][Settings] "Marketplace" and "Find My Device" within Firefox Accounts page are not functional buttons → [B2G][Settings][Firefox Account] "Marketplace" and "Find My Device" within Firefox Accounts page are not functional buttons
(Reporter)

Comment 2

4 years ago
Created attachment 8454805 [details]
logcat_firefox.txt
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Back to ? mark - this is missing a needinfo to the component QA lead to triage the bug.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
William - you are QA Lead for Find-My-Device I believe?
Flags: needinfo?(whsu)

Comment 5

4 years ago
(In reply to Joshua Mitchell [:Joshua_M] from comment #4)
> William - you are QA Lead for Find-My-Device I believe?

ha~ No, I am not the right person to ask.
Kate may know the answer.
- kglazko@mozilla.com
Have a nice day! :)
Flags: needinfo?(whsu)
This bug is invalid - AFAIK the buttons are not supposed to be functional.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Clearing my need info.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.