Closed Bug 1037864 Opened 8 years ago Closed 8 years ago

[GaiaGrid] Serve localization from within the gaia grid component

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S1 (1aug)

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [p=1],[systemsfe])

Attachments

(2 files)

It's more clear when the locale files come from the component. Let's do the same thing we did in the menu, and serve the files from the component folder.
Attached file Github pull request
Summary: [GaiaGrid] Sever localization from within the gaia grid component → [GaiaGrid] Seve localization from within the gaia grid component
Summary: [GaiaGrid] Seve localization from within the gaia grid component → [GaiaGrid] Serve localization from within the gaia grid component
Comment on attachment 8454917 [details] [review]
Github pull request

Cristian could you take a look at this? Note: to successfully test this, you would also need the patch from bug 1032261. (I think I would like to land them together to standardize on a solution).

Thanks!
Attachment #8454917 - Flags: review?(crdlc)
Comment on attachment 8454917 [details] [review]
Github pull request

LGTM, just a comment in github
Attachment #8454917 - Flags: review?(crdlc) → review+
Target Milestone: 2.0 S6 (18july) → 2.1 S1 (1aug)
Kevin, we ready to land this bad boy?
Flags: needinfo?(kgrandon)
(In reply to Michael Henretty [:mhenretty] from comment #4)
> Kevin, we ready to land this bad boy?

I was kind of waiting to see what the web components land would look like, but since we have some more coming, and you asked - let's do it :)
Flags: needinfo?(kgrandon)
Waiting for bug 1032261 to re-run on CI then will land this as there is a dependency.
Depends on: 1032261
Master: https://github.com/mozilla-b2g/gaia/commit/c64391365de44f9e531af24c900cfea09f0b8eaa
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
I think there's a regression from this patch. The path in locales.ini should be relative to its location.

Right now this: https://github.com/mozilla-b2g/gaia/blob/add5d975a7e0028d9787e5beb8346ac94ba60c34/shared/elements/gaia_grid/locales/locales.ini points to non existing dir shared/elements/gaia_grid/locales/gaia_grid/gaia_grid.{locale}.properties
Thanks for noticing Zibi!

Going to give this a test run, and if it looks alright I'll flag you for review if that's ok.
Comment on attachment 8465019 [details] [review]
Pull request - Follow-up, fix property file paths

Hey Zibi - verified that the strings work with the test locales. Wanted to flag you for review to make sure we're doing the right thing here. Thanks as always.
Attachment #8465019 - Flags: review?(gandalf)
Attachment #8465019 - Flags: review?(gandalf) → review+
You need to log in before you can comment on or make changes to this bug.