Inspector tooltip text has unwanted text-shadow with certain light-weight themes

RESOLVED FIXED in Firefox 33

Status

DevTools
Inspector
--
minor
RESOLVED FIXED
4 years ago
a month ago

People

(Reporter: Mark Bokil, Assigned: bgrins)

Tracking

Trunk
Firefox 33

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8454951 [details]
inspector-retina-blurry-tooltip.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140710141843

Steps to reproduce:

Open inspector and inspect an element on a OS X retina device like macbook pro


Actual results:

tooltip text is readable but blurry (over aliased). see attached screenshot of text issue.


Expected results:

tooltip text should be sharp
(Reporter)

Updated

4 years ago
Severity: normal → minor

Comment 1

4 years ago
I can't reproduce this. Can you check if you can reproduce this if you restart with add-ons disabled (option in the help menu)? And do you perhaps have a theme installed/enabled?
Component: Untriaged → Developer Tools: Inspector
Flags: needinfo?(mark.bokil)
(Reporter)

Comment 2

4 years ago
I confirmed it was the silver2 theme interacting with the tooltip. Marking as resolved invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mark.bokil)
Resolution: --- → INVALID

Comment 3

4 years ago
Because silver2 is a "light-weight theme", it's still Firefox's responsibility to make the text in its tooltips look good in that case, so I'm reopening this.

The issue is that for lightweight themes with a certain background/foreground color, we set a bright text shadow. That's what you're seeing here. Because the text shadow doesn't work well in this case, the inspector's CSS should include a line or two to disable it in such cases.

Theme: https://addons.mozilla.org/en-us/firefox/addon/silver2/
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Summary: Inspector tooltip text is blurry on OS X retina monitor → Inspector tooltip text has unwanted text-shadow with certain light-weight themes
(Reporter)

Comment 4

4 years ago
I see your point. Other light-weight themes may also show the blurring from the shadow and users will most likely see it as a Firefox bug.
(Assignee)

Comment 5

4 years ago
Created attachment 8458016 [details] [diff] [review]
fuzzy-text.patch

There is a text shadow applied to :root:-moz-lwtheme-darktext and :root:-moz-lwtheme-brighttext.  This removes it for the infobar
Assignee: nobody → bgrinstead
Status: REOPENED → ASSIGNED
Attachment #8458016 - Flags: review?(mratcliffe)
(Assignee)

Updated

4 years ago
OS: Mac OS X → All
Hardware: x86 → All
Version: 31 Branch → Trunk
Attachment #8458016 - Flags: review?(mratcliffe) → review+
(Assignee)

Updated

4 years ago
Attachment #8458016 - Flags: checkin+
https://hg.mozilla.org/mozilla-central/rev/dc73c687701d
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.