java.lang.RuntimeException: Subclasses of PreferenceActivity must override isValidFragment(String) to verify that the Fragment class is valid!

RESOLVED DUPLICATE of bug 992938

Status

()

Firefox for Android
Settings and Preferences
RESOLVED DUPLICATE of bug 992938
4 years ago
4 years ago

People

(Reporter: dougc, Unassigned)

Tracking

31 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Testing a local build of Firefox for Android Beta 31. When Firefox is uninstalled and reinstalled, and when it is then started cold, it has been crashing with the follow Java error that appears to point to a programming error. The device is a Nexus 4 with Android 4.4.3.

E/GeckoAppShell(12397): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
E/GeckoAppShell(12397): java.lang.RuntimeException: Subclasses of PreferenceActivity must override isValidFragment(String) to verify that the Fragment class is valid! org.mozilla.gecko.preferences.GeckoPreferences has not checked if fragment org.mozilla.gecko.preferences.GeckoPreferenceFragment is valid.
E/GeckoAppShell(12397): 	at android.preference.PreferenceActivity.isValidFragment(PreferenceActivity.java:898)
E/GeckoAppShell(12397): 	at android.preference.PreferenceActivity.switchToHeaderInner(PreferenceActivity.java:1179)
E/GeckoAppShell(12397): 	at android.preference.PreferenceActivity.switchToHeader(PreferenceActivity.java:1199)
E/GeckoAppShell(12397): 	at android.preference.PreferenceActivity.onCreate(PreferenceActivity.java:545)
E/GeckoAppShell(12397): 	at org.mozilla.gecko.preferences.GeckoPreferences.onCreate(GeckoPreferences.java:117)
E/GeckoAppShell(12397): 	at android.app.Activity.performCreate(Activity.java:5231)
E/GeckoAppShell(12397): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1087)
E/GeckoAppShell(12397): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2148)
E/GeckoAppShell(12397): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2233)
E/GeckoAppShell(12397): 	at android.app.ActivityThread.access$800(ActivityThread.java:135)
E/GeckoAppShell(12397): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1196)
E/GeckoAppShell(12397): 	at android.os.Handler.dispatchMessage(Handler.java:102)
E/GeckoAppShell(12397): 	at android.os.Looper.loop(Looper.java:136)
E/GeckoAppShell(12397): 	at android.app.ActivityThread.main(ActivityThread.java:5001)
E/GeckoAppShell(12397): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoAppShell(12397): 	at java.lang.reflect.Method.invoke(Method.java:515)
E/GeckoAppShell(12397): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:785)
E/GeckoAppShell(12397): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:601)
E/GeckoAppShell(12397): 	at dalvik.system.NativeStart.main(Native Method)
(Reporter)

Updated

4 years ago
Summary: java.lang.RuntimeException: Subclasses of PreferenceActivity must override isValidFragment(String) to verify that the Fragment class is valid! org.mozilla.gecko.preferences.GeckoPreferences has not checked if fragment → java.lang.RuntimeException: Subclasses of PreferenceActivity must override isValidFragment(String) to verify that the Fragment class is valid!
(Reporter)

Comment 1

4 years ago
Tapping the 'Settings' menu item also invokes this crash.

The official Beta builds do not seem to have this issue. Might be an issue with the DEBUG build or a difference in the build tools.
You need to build with a newer targetAPI. See Bug 992938.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 992938
You need to log in before you can comment on or make changes to this bug.