Implement Ctrl+PgUp and Ctrl+PgDn to switch tabs

VERIFIED FIXED

Status

SeaMonkey
Tabbed Browser
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: David Gerard, Assigned: Brian Ryner (not reading))

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4+) Gecko/20011007
BuildID:    2001100708

According to bug 100706 , it should be possible to cycle between tabs
using Ctrl+Tab or Ctrl+Shift+Tab. Reports in that bug say it doesn't
work in XP or 2000 as well as NT. I'm posting this report to separate
out the issue from the general bug.

Reproducible: Always

Steps to Reproduce:
1. Open a new tab (Ctrl+T).
2. Press Ctrl+Tab or Ctrl+Shift+Tab

Actual Results:  Nothing happens.

Expected Results:  Cycle between tabs.

This is hardly earth-shattering, but it is a bug.

Comment 1

17 years ago
might be related to 69954 (ctrl-alt not working on win32)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
I thought ctrl+tab was supposed to switch between tabs in tabbed dialogs and 
between panes and frames in the browser and mail windows.  What do you do when 
a window has both tabs and panes?  (By the way, one of the reasons I'm opposed 
to the tabbed browser feature is that it clutters both the screen and the 
keyboard UI by implementing features redundant with those of any reasonable 
window manager.)

Comment 3

17 years ago
I agree 100% with Jesse Ruderman
(Reporter)

Comment 4

17 years ago
Jesse Ruderman: "By the way, one of the reasons I'm opposed 
to the tabbed browser feature is that it clutters both the screen and the 
keyboard UI by implementing features redundant with those of any reasonable 
window manager."

Cool. What window manager do you suggest we use on Windows, MacOS (8/9 and X),
OS/2, etc? (Maybe NT will run fvwm95 ...)

Ctrl+Tab and Ctrl+Shift+Tab don't work in win98 either, 0.9.5 & 2001-10-14-11-trunk.
Summary: Tabbed Browser: Ctrl+Tab and Ctrl+Shift+Tab don't work in Windows NT/2000/XP → Tabbed Browser: Ctrl+Tab and Ctrl+Shift+Tab don't work in Windows
*** Bug 104805 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
*** Bug 105117 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Not working on UNIX either. A tab switch hot key would be very nice. So would a
tab close hotkey.
OS: Windows NT → All
Hardware: PC → All

Comment 9

17 years ago
*** Bug 105524 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
Jeremy, it does work on UNIX. Tested with 0.9.5 and 2001101808, Linux.
Make sure your window manager doesn't bind those keys.
For tab close hotkey, see bug 102602.

Comment 11

17 years ago
You're right, does work on UNIX. It doesn't wrap around as expected, which is
why it didn't appear to work for me.

On the subject of tab switching hotkeys, I think it would be ideal if I could
bind meta+1/2/3 to bring up tab 1/2/3. Alot of people on UNIX use that type of
system to flip through the equivilent of tabs in IRC clients, or desktops in
their window manager. This avoids having to render tab 3 and 4 when you want to
jump from 2nd to 5th. Alt or Meta should be free... Ctrl+numbers already
launches the tasks (ugg, what a waste of good hotkeys). If the window manager
has meta+numbers bound, then it's no big loss.
OS: All → Windows 98
Hardware: All → PC

Comment 12

17 years ago
I agree - ALT-1/2/3/../9/0 would be useful and maybe even ALT-Q/W/E/R/T/Y/.. for
tab #11/#12/.. could be used there (my favorite IRC-client (Irssi) does that).

Another minor issue is how Ctrl-Tab should work - in numerical order (1, 2, 3,
.., n, 1, 2) or historical order (last used tabs in reverse order, like alt-tab
does on Windown). Probably numerical order is better option there.

Comment 13

17 years ago
Reassigning to bryner who can close out or morph into the bug to make CTRL+pgup
and pgdown work for tabbrowser.
Assignee: hyatt → bryner
*** Bug 106262 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
Now this is broken on UNIX, too... Build 2001102406, Linux.

 

Comment 16

17 years ago
This is intentional.

Ctrl+PgUp/Ctrl+PgDn are going to be used for this, because of the multiple
conflicting purposes of Ctrl+[shift]+Tab (it also needs to do pane+frame
navigation). It would be extremely complicated to code Mozilla to navigate
several tabbed pages, where each page might have several frames. It would also
be a little messy in terms of the tab order.
 
The solution we came up with is here:
http://www.mozilla.org/projects/ui/accessibility/newnav.html

Please take a look at that. In short, Ctrl+pgup and Ctrl+pgdn will be used to
navigate the tabbed browser tabset.
Therefore, this bug should really be about Ctrl+PgUp/Ctrl+PgDn not working to
navigate tabset (all platforms)

Comment 17

17 years ago
I would argue that people will want to navigate between TABs *far* more often
than navigate between frames. 

Therefore the TAB navigation should be the more accessible. Therefore CRTL+Tab
should be for TAB-switching, and PG-UP/DWN should be for FRAME navigation.

Tshing ... 2cents
(Assignee)

Comment 18

17 years ago
Ctrl+Tab is going to be reserved for frameset navigation with tabbrowser.  As
hyatt mentioned, Ctrl+PgUp/Ctrl+PgDn will be hooked up as alternate
tab-switching keys that will work in tabbrowser.  Updating summary.
Summary: Tabbed Browser: Ctrl+Tab and Ctrl+Shift+Tab don't work in Windows → Implement Ctrl+PgUp and Ctrl+PgDn to switch tabs
Severity: minor → normal
Keywords: access
OS: Windows 98 → All
QA Contact: blakeross → sairuh
Hardware: PC → All

Comment 20

17 years ago
sr=hyatt

Comment 21

17 years ago
Comment on attachment 55197 [details] [diff] [review]
patch

r=pchen
Attachment #55197 - Flags: superreview+
Attachment #55197 - Flags: review+
(Assignee)

Comment 22

17 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 23

17 years ago
If you care about usability at all I would strongly consider reversing this to
use ctrl-tab/ctrl-shift-tab on the Windows platform at least as these are the
standard keystrokes for switching between MDI windows (which has been carried
forward by newer apps which have abandoned the MDI interface in favour of tabbed
interfaces like mozilla's tabbed panes).  There's nothing worse than an app that
ignores the conventions of the platform it's running on.

It would make sense to use ctrl-pgup/ctrl-pgdn for switching focus between
frames since these keys don't have standard usage likely to confuse users, at
least that I'm aware of.

Comment 24

17 years ago
No, Ctrl+PgUp/Ctrl+PgDn are in fact standard for switch tabs as well. For
example, try Tools - Options in outlook express.

Usually Ctrl+[shift]+tab does that as well, but we need that to work for frame
navigation, which is something else that key normally does. It didn't work out
to have Ctrl+[shift]+tab do both, so we had to make some choices.

If you read 
http://www.mozilla.org/projects/ui/accessibility/newnav.html

you'll see our reasoning process.
- Aaron

Comment 25

17 years ago
Right, I understand there's a conflict.  Here's a link to the relevant page in
Microsofts UI "bible": <a
href="http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnwue/html/appxb.asp">Keyboard
Interface Summary</a>

Specific mention is made of ctrl-tab:
  "Display next tabbed page or child window (MDI)"

which seems to exactly describe the process of switching tabs in the new mozilla
tabbed interface.  (No mention is made of ctrl-pgup/pgdn).  Looking to IE for
direction is kind of bogus since it has no analogue to the tabbed-documents
interface.  I think it makes more sense (and causes less confusion) to use the
existing standard (ctrl-tab) properly and adopt the non-standard ctrl-pgup/pgdn
where there's a conflict (ie to navigate between frames.)

I know this is kind of pedantic but then again usability has always been about
splitting hairs. ;)

Comment 26

17 years ago
Build 2001102608: Ctrl+PgUp switches to the previous tab and Ctrl+PgDn to the
next tab. Shouldn't it be the other way around?

(Also, I would really appreciate it if there was at least an option to use
Ctrl[+shift]+tab instead of Ctrl+PgUp/PgDn for tab navigation...)
*** Bug 108210 has been marked as a duplicate of this bug. ***
*** Bug 108587 has been marked as a duplicate of this bug. ***

Comment 29

16 years ago
BTW Ctrl+PgUp/PgDown is for lot of people two-hands key combination or all
right-handed users have to move out right hand from mouse...  For me and several
my friends isn't Ctrl+PgUp/PgDown useful, it is very 'slow' navigation.

Could be this keyboard combination setted via preferences? (for example national
keyboards changing shortcut could be setted in Windoze).

BTW 2 Opera has ctrl+tab to switch tabs.

Comment 30

16 years ago
IMO all or almost all keyboard-shortcuts should be user-definable - that would
also solve this problem. Many people would like to use shortcuts like Alt-Z or
Alt-X (on normal QWERTY) for back/forward or changing tabs. Is there a bug for that?

tested in both tabbed-browser and tabbed-dialog; vrfy fixed using commercial
verif bits:

linux [rh6.2] - 2001.11.06.12
winnt - 2001.11.06.12
mac 10.1 - 2001.11.06.08
Status: RESOLVED → VERIFIED

Comment 32

16 years ago
For "remap all key bindings" see
http://bugzilla.mozilla.org/show_bug.cgi?id=57805 . It really is not easy task
because Mozilla defines key bindings on way too much places...

Comment 33

16 years ago
I agree that ctrl+tab and ctrl+shift+tab make more sense that pgup/down. To 
switch between tabs in a dialog you should just have tab and shift tab as in 
<I>another popular browser</I>

Comment 34

16 years ago
Using <Tab> to switch between MDI tabs is more common than using it to switch 
between frames/panes.  Given a conflict, <Tab> should do be assigned to MDI tab 
switching.  I agree with other criticism that this resolution is counter-
intuitive and should be reversed.
*** Bug 110913 has been marked as a duplicate of this bug. ***

Comment 36

16 years ago
Sorry, got to reopen this issue. Cannot use ctrl-up/down from within
URL-inputfield. Once you're inside the actual page, the shortcuts work fine but
not from within the URL field.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 37

16 years ago
Sorry, one last note: this keyboard shortcut is totally undocumentation. Please
*please* document it somewhere.

Comment 38

16 years ago
I agree that "Ctrl+PgUp and Ctrl+PgDn to switch tabs" is not intuitive at all.
Opera uses Ctrl-Tab, Excel uses Ctrl-Tab, Homesite uses Ctrl-Tab, actually every
Windows Application I can think of, that has some sort of child windows uses
Ctrl-Tab. Why doesn't Mozilla?
Besides, Ctrl-Tab would even make sense for no-tabbed browsing, so you could
cycle between different windows of the Mozilla application..

Arhu

Comment 39

16 years ago
Why don't we make everyone happy and support both CTRL-TAB (which I hate <g>) 
and CTRL-PAGEUP/PAGEDOWN?

Comment 40

16 years ago
Gili: Ctrl+Tab is already used to switch between panes and among content area 
frames (see Aaron's comment #24).  So using Ctrl+Tab for switching between tabs 
wouldn't "make everyone happy".

I filed bug 114170 for this shortcut not working in the location bar, so 
resetting this bug to fixed.

Keyboard shortcut documentation (as part of Help) is bug 84622.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 41

16 years ago
Look whatever ctrl+tab does, it does not do what a lot of other software
programs do: switch between tabs. Now it may be not the best thing but it would
make a lot more sense if it switched between tabs. 

Anyway don't make it switch between tabs if you don't want to, but at least 
let me tell you why I find ctrl pgup/dn the most annoying thing (so annoying
that I don't use it): the tab switch should be performed with the right hand
only, otherwise I have to move the left hand from the mouse and at that point I
can do the tab switch directly with the mouse (which is what I currently do, and
I hate it). Make it ctrl+`, ctrl+1, ctrl+2, whatever, but not ctrl+pgup (which
would be bad even for people that don't use the mouse since you have almost to
look at the keyboard to find it). 

Comment 42

16 years ago
a) You're left handed, most people are not. Not to discriminate against you but 
you've got to keep that in consideration.

b) You can use ctrl-pageup/pagedown quite easily using your right hand.. 
Extremely easily in fact.. You just place your thumb on ctrl and use your 
fingers to hit pageup/pagedown.. Extremely easy on my end. Maybe you're using a 
non-standard keyboard?

c) The whole world doesn't revolve around the Windows operating system. Just 
because Windows does it a certain way doesn't mean other OSs should when 
Mozilla is run on them.

Comment 43

16 years ago
a) no he's not
b) as he said (read slower next time), you have to release the mouse to do so,
so you may as well just click the damned tab.

Comment 44

16 years ago
Heh, let's flooding start! I never use right CTRL, really do not. Why? Because
I'm right-handed so my right hand operates with mouse. Suprise? ^_^ So tell me
why CTRL+PgDn/Up is so extremaly usefull for right-handed people when they first
get their right hand off the mouse - the most important device for the browsing.

Shhh... I'm pretty sure we can't even make it a prefference, so we should
provide patch somewhere else and look how many people will download it ^_- (But
providing patch for anything else than 1.0 is selfkiller thing.)

Comment 45

16 years ago
i think that this thread constitutes a good argument for some form of keymapping
utility, a la a .vimrc

Comment 46

16 years ago
There is the bug for it - see #57805 . But there are a lot of problems, because
there is no such thing as "central key-mapping table" in Mozilla...

Comment 47

16 years ago
Filed bug 114725 to fix the keybinds back.

Comment 48

16 years ago
Look..

Enough is enough.. obviously we have two groups of thought on this issue but 
nothing will come of any of this until the keyboard remapper is complete.

I am wholly against CTRL-TAB as a shortcut because it is retarded to use CTRL-
SHIFT-TAB as a shortcut for anything.. Shortcuts should not be composed of 
three characters.. CTRL-PAGEUP/PAGEDOWN or (more to the point) CTRL-<arrowkey> 
is much easier to work with than any 3-character shortcut. I would be willing 
to resort to other shortcuts you might want to suggest, but this one is 
ridiculous.

Comment 49

16 years ago
I have a standard keyboard/mouse layout, I'm right-handed, and I'm quite
annoyed that the switch-between-tab shortcut requires me to take my right
hand off the mouse.  That's not a shortcut!  It saves me no time at all;
I might as well mouse around clicking the tabs.

Using Ctrl+Pg* to cycle between tabs is extremely unintuitive to me (maybe
it's different for people coming from Windows/IE?  I dunno).  It would never
have occurred to me to try that combination.

Not being able to do it at all with my left hand only means that the feature
is essentially useless.

Comment 50

16 years ago
Filed bug 114974 to find a better keybind for tabs.

Comment 51

16 years ago
That bug you submit has been resolved as wontfix which is incredible. ctrl+pgup
is very bad for those using mouse with the right hand. It is moderately bad for
those using the mouse with the left hand (they can use the combination with the
right hand but I bet they miss it 50% of the times since pgup is rarely used).
Same goes for people not using mouse at all.

Admit it you don't want to do it because it's painful, and because someone is 
going to implement key mapping someday. Still that's no justification because
even if I implement my preferred mapping on my browser, on any other computer I
will find the stupid default ctrl+pgup.

Please give one justification why ctrl+pgup is a good combination and I'll shut
up. Right now I can't see any in your arguments. Please change it to ctrl+t (t
for tab).

Comment 52

16 years ago
CTRL-TAB is a bad shortcut because it requires 3 keys to move backward (CTRL-
SHIFT-TAB). That is your one reason.

CTRL-PAGEUP/PAGEDOWN might not be perfect but you're never required to hit more 
than 2 keys at a time.

Comment 53

16 years ago
As discussion continues here and my other bugs (114725 and 114974) were
WONTFIXed almost immediatly, I'll paste my suggestion here.

> My suggestion is mod+1/2/3/4/etc, where mod is differant from the one used in
> tasks (which should eventually go away, but that's another story). This is a
> somewhat common keybind in UNIX apps to switch between differant viewable
> regions in apps (window managers, IRC clients...), so it's worked in the past
> for this purpose.

This is left hand only so it's actually useful, unlike the current bind. I don't
see how anyone can say this is WORSE then what's we have currently, and I think
most people here will agree it's (much) better.

114974 was WONTFIXed on the basis that "we can't make everyone happy so let's
not even try", EVEN IF the current bind makes NO ONE happy.

If configurable keybinds were right around the corner, that'd be one thing, but
I reaaaaaly don't see them making it in the next 12-18 months at all. It's a
major MAJOR change to hook all the events up to a configuable keybind system.
Let's please have a sane default until Mozilla 2.0.

Comment 54

16 years ago
> CTRL-TAB is a bad shortcut because it requires 3 keys to move backward (CTRL-
> SHIFT-TAB). That is your one reason.
> 
> CTRL-PAGEUP/PAGEDOWN might not be perfect but you're never required to hit
> more than 2 keys at a time.

Ctrl-Shift-Tab is easy to use even with one hand. Most people are right handed, 
and use the mouse with their right hand. Ctrl-Tab and Ctrl-Shift-Tab are easy 
to use with the left hand, while the right hand is on the mouse. Ctrl-PgUp/PgDn 
requires you to switch your hand from the mouse to the keyboard.

There are still other suggestions though, like Alt/Ctrl/Shift-
ArrowLeft/ArrowRight. Or the one used in xchat, but I forgot what it was.

Comment 55

16 years ago
Sorry, I have to disagree.

My view (and you have the right to disagree) is that you either use the mouse 
exlusively or the keyboard but not both. Anyone who thinks a 3-key shortcut is 
good because it's "easy to reach" is still missing the point here: it requires 
3 keys.. I couldn't care less how easy it is to reach in the first place, it is 
very ackward to use for repeatitive movement across tabs. I might as well use 
1980-style shortcuts of CTRL-K + <some character>..

Point being: If you want browsing efficiency, use the keyboard and stop 
bitching. Otherwise use the mouse and live with the slowness :) Mouse users 
suck anyway :) :)

<grin> Just my 2 cents..

Comment 56

16 years ago
> My view (and you have the right to disagree) is that you either use the mouse
> exlusively or the keyboard but not both.

Mozilla is a browser, it's not vi. I fail to see how one can easily surf and 
follow links without using the mouse. And not using the keyboard is no option: 
there are URLs to type and forms to fill in.

> Anyone who thinks a 3-key shortcut is good because it's "easy to reach" is
> still missing the point here: it requires 3 keys.. I couldn't care less how
> easy it is to reach in the first place, it is very ackward to use for
> repeatitive movement across tabs. I might as well use 1980-style shortcuts of
> CTRL-K + <some character>..

As far as I'm concerned, the ease of use is the only criterium. I don't have 
any problem pressing 3 keys at the same time, even if I have to do it 
repeatedly. Easier than constantly switching from mouse the keyboard and vice-
versa. Ctrl-K, OTOH, is not good. Ctrl and K are too far apart to easily use 
with one hand.

> Point being: If you want browsing efficiency, use the keyboard and stop
> bitching. Otherwise use the mouse and live with the slowness :) Mouse users
> suck anyway :) :)

And how am I supposed to browse efficiently using only the keyboard? If you 
know how to do it, I'm genuinely interested.

Comment 57

16 years ago
My 2 cents:
Using both mouse and keyboard in one time is common for power-users. Combination
of one hand for shortcuts and one hand for rest navigation/controls by mouse is
most powerfull.

Ctrl+PgUp/Ctrl+PgDn is usefull only when both hands are on keyboard, but if
there is only one hand on keyboard, this combination is useless.

Ctrl+Tab/Ctrl+Shift+Tab is common shortcut on Win platform (switching between
aplications), futhermore, you can hit Ctrl+Shift+Tab with two fingers of one hand. 

Comment 58

16 years ago
>Mozilla is a browser, it's not vi. I fail to see how one can easily surf and 
>follow links without using the mouse. And not using the keyboard is no option: 
>there are URLs to type and forms to fill in.

    Most mouse users never type in URLs. And say they decide they need to
(because they don't have the link saved anywhere) they get both hands off the
mouse anyway because no one is going to type in a URL using one hand. Once
again: it's all keyboard or all mouse but not both.

>And how am I supposed to browse efficiently using only the keyboard? If you 
>know how to do it, I'm genuinely interested.

   I have browsed using only the keyboard for a long long time. Just use
pageup/pagedown to scroll up/down the page. If you really must jump to a certain
input box, use the mouse to go there and then go back to full-keyboard to type
in the input type.. Point being, I never mix keyboard and mouse.. I use one or
the other.

>My 2 cents:
>Using both mouse and keyboard in one time is common for power-users. >Combination
>of one hand for shortcuts and one hand for rest navigation/controls by mouse is
>most powerfull.

   No need for that.. You can save most of these shortcuts into your mouse
anyway. I know my friend at work has a 5-bottom mouse <grin> and she has all her
favorite shortcuts built into it. Besides, you can always right-click for most
of the same shortcuts... Power users don't need a mix of mouse and keyboard.
Power users needs the keyboard 99% of the time and the mouse for 1% of the time
if you want to click on some visual link or input-box. The rest of the time
scrolling or inputting text can be done directly using the keyboard.

Comment 59

16 years ago
ROTFL... So when Mozilla had no tabs you'd changed windows by mouse clicking on
them and hadn't used some keybord shortcut (I bet ALT+TAB)? Sorry, but I really
don't understand why my hand work with Mozilla should change only because I have
multiply tabs in one window now instead of multiply browser-windows as before.

The only partially acceptable reason for me why tabbed-Mozilla has no CTRL+TAB
is that this was used for something else ages before. That almost nobody ever
uses this is another story...

Comment 60

16 years ago
> I have browsed using only the keyboard for a long long time. Just use
> pageup/pagedown to scroll up/down the page.

Here you're saying you never use the mouse...

> If you really must jump to a certain input box, use the mouse to go there and
> then go back to full-keyboard to type in the input type.

Now you're saying one has to use the mouse sometimes. And you still haven't 
answered my question: how do you 'click' a link not using the mouse? TABbing 
all the way untill you reached the umpteenth link on a page is not an option, 
IMHO.

> Point being, I never mix keyboard and mouse.. I use one or the other.

The one or the other, so you have to switch between them. Me too, and I want to 
(1) keep the amount of switching to a minimum and (2) keep the time required to 
do it to a minimum.

> ... Power users don't need a mix of mouse and keyboard.
> Power users needs the keyboard 99% of the time and the mouse for 1% of
> the time if you want to click on some visual link or input-box. The rest of
> the time scrolling or inputting text can be done directly using the keyboard.

Well, isn't that a mix of keyboard and mouse?? That's the whole point, browsing 
is a mix of clicking visual links and input-boxes, scrolling and inputting 
text. Now changing from one input box to another can be done using either the 
mouse or the keyboard, and the same goes for scrolling. But clicking links can 
not be done efficiently without the mouse, and entering text is not efficient 
without using the keyboard.
I consider myself to be a power user, and when I'm browsing I find myself very 
often switching between mouse and keyboard. 

Comment 61

16 years ago
To the administrator that deliberately changed my post.
I would like to inform you that when I suggested ctrl+t I really meant ctrl+the
letter t (I didn't mean t for tab). My argument is: "t" can be reached by the
left hand while pressing ctrl. 

I don't see why there should be ideological stands on an issue like this. Ctrl
Pgup can't be good because ctrl_shift_tab is bad. If anything they are both bad.
Ctrl+arrow is equally bad. 

Comment 62

16 years ago
> Power users needs the keyboard 99% of the time and the mouse for 1%

You're obviously an idiot. Mozilla's keyboard nav is awful, "power users" are
not using it 99% of the time. The only people using any ammount of keyboard nav
are disabled people. And I'm sure they're all using IE right now, where there
aren't 1000 focus issues that make you alt+f4 and restart to get keyboard
working again.

That said, many actions are quicker to hit a hotkey for then target the mouse to
a menu/button, click, and then move back to the page. Tab switching it one of
them. Tab's are tiny targets, far away from the scroll bar and links on pages
where the mouse is likely to be. Also, there are times when they're swaped
between frequently. Because of this, a left hand keyboard shortcut would make
navigation much easier. One that requires the right hand isn't at all useful to
right handers, as it's quicker just to target the tab, click it, and move the
mouse back.

I still have heard no reasons why mod+1/2/3/4/5/etc shouldn't be implemented for
tab switching. It's easily left-handable, and has the bonus of being able to
jump right from tab X to tab Y, and back, without rending Z number of pages
between them. One of the mods is used for "task" opening, which is dumb, but
there's plenty left. Pick one. And get rid of the current keybind which is
pretty much useless. Alt, meta, and shift are left on UNIX. Windows should be
the same, but there meta is used by the OS only, I think (meta being the
"windows" key). So alt sounds good for UNIX and Win, as meta+1/2/3 is often used
by UNIX window managers, though that's always remapable, since window managers
are sane apps and allow for that sort of thing :).

Comment 63

16 years ago
We all know no one is going to budge about who is "more right".   By the result
of bug 114974, its seems Ctrl+Pgup/Pgdn is what we're stuck with.

Without the major coding of a "central key-mapping table", is there any way to
let those of us that want Ctrl+Tab or Ctrl+Shift+Tab use it or is it something
we should just live with and move on?  Yes, those of you that like it as is will
say "live with it", but it seems there's a good number of us that dislike it. 
Are we -really- stuck with it?

Comment 64

16 years ago
No need to resort to name calling. I am very much aware how nice and buggy the 
Windows version of Mozilla is (tons of focus issues). However, I am using the 
OS/2 version which is lightyears ahead of the Windows ver. We have no focus 
issues and keyboard-oriented browsing works great.

Your experience may vary, but keep in mind many of these bugs you're bringing 
up are platform-specific. Just because it doesn't work on your platform doesn't 
mean Mozilla has poor support for the keyboard.

Comment 65

16 years ago
> Mozilla's keyboard nav is awful, "power users" are
> not using it 99% of the time.
[...]
> Tab's are tiny targets, far away from the scroll bar and links on pages
> where the mouse is likely to be. Also, there are times when they're swaped
> between frequently.

I agree completely.  Keyboard-only navigation is basically impossible given
the sheer number of links on an average webpage.  People who /can/ use a
mouse /must/ use a mouse, else they'd be sitting there TAB'ing all day, waiting
for the correct link to be highlighted.

The argument that "Ctrl-Tab is bad because then you have to use Shift-Ctrl-Tab
to go backwards, and that's 3 keys instead of 2" is utterly ridiculous.  Doesn't 
shifting through the tabs cycle around??  (If not, why not?)  Using those 3
keys is still faster than taking my hand off the mouse and finding the
PgUp/PgDown keys.

So far all I've seen are the Mozilla volunteers on one side, saying that
PgUp/PgDown is good because that's what's in place, and all the users on the
other side, saying that's not what we want.  :-)

Please AT LEAST give us instructions for changing the mapping in the source
code, so that we can compile our own local unfucked version.

Comment 66

16 years ago
> The argument that "Ctrl-Tab is bad because then you have to use Shift-Ctrl-Tab

no no no no no. Forget about ctrl+tab and ctrl+shift+tab. They're gone. Gone for
pane focus, for accessibility reasons. Even though pane switching is only useful
to disabled people, apperantly ctrl+pgup/down isn't garunteed to be on all
keyboards (I've never seen one without it, even laptops, but, whatever).

This is why I came up with and have been suggesting mod+1/2/3/4, which I think
is superior for tabs anyway, IMO. So please, enough about ctrl+tab. Yes,
ctrl+pgup/down reaaaaally sucks. Yes we need a *new* bind. But argue against
pgup/down, not FOR a key that MUST stay for accessibility.

Comment 67

16 years ago
> Gone for pane focus, for accessibility reasons.

That is a very poor reason. We should be striving for the most good for the most
users. Why waste a good shortcut for a very few disabled persons for a very
rarely used feature. I suggest to give pane switching another (less used)
binding (e.g., mod+#), and give Tab switching to (the much requested) Tab
switching. Tab bind for Tabs switching, what could be more obvious?

Comment 68

16 years ago
Peter just reenforced my suspicions. You guys are idiots :) I'm outta here.. 
Maybe one day you'll stop whining.

Comment 69

16 years ago
[OT]
Gili, what is "idiotic" about the assumption that there will be more Tab-switch
users than disabled persons? It may be an incorrect assumption, but certainly
not idiotic. Also, in comment #64 you remind not to resort to namecalling, yet
you call everyone in this bug "idiots" and "whiners".
[/OT]

For the record, I don't really like the idea of MOD+1,2,3,... because it
requires keeping the left thumb on the MOD key and then precisely navigating
each of the number keys to get a specific Tab. Plus, how are the Tabs to be
numbered - from left to right, from last opened to first opened? Either way, you
have to first count the tabs and then find the corresponding number key. IMHO,
way too cumbersome. I much prefer just cycling through the Tabs by banging on
CTRL+TAB until I get the page I want. Less looking for keys = less hastle. 

My comment #67 give as yet undisputed reasoning why the TAB key should be used
for Tab switching.

Comment 70

16 years ago
Hahaha, another man against CTRL+TAB just removed himself from Cc not forgetting
to call us idiots before doing so... Don't you all think there's something
really bad here? (In fact it looks like some newsgroup flamewar ;-)

Comment 71

16 years ago
1) what is the "mod" key in a widows keyboard?
2) I agree that the argument about using mode/1/2/3/4 being a bit complicated 
(which is tab 1,2,3..4.  what's bad about ctrl+2 for "next tab" and ctrl+1 
for "prev. tab"?
3) Is the owner of this bug aware of the debate and if yes can he state 
some "official" position on the issue? I think we're all getting tired that for 
a stupid little code change (probably 3 lines) we're going to a horrible flame 
war. I think the position against pgup/pgdn have been all very well motivated. 
The position not to change ctrl+tab have been explained. I have not yet seen 
why there seems to be some resistance to change ctrl+up/dn to some other 
combination (different from ctrl+tab) but accessible with the left hand only
(Assignee)

Comment 72

16 years ago
My official position on this is that I'll implement whatever aaronl decides is
best, since he's the owner of the keyboard navigation spec.
..and re-verifying.
Status: RESOLVED → VERIFIED

Comment 74

16 years ago
Ctrl+1 is mapped to switch between browser windows, and Ctrl+2 is Mail (see the
tasks menu)

And FWIW, please put some serious keybinding, not this impossible Ctrl+Pg that
I'll never use because is just faster to switch tabs with the mouse than to move
the hand to the keyboard.

Comment 75

16 years ago
Yes, the current keybinding mine as well not even exsist. Unfortunately you
missed and lost (along with every other user) that battle. Bug 113880 and bug
114725 are both marked WONTFIX.
*** Bug 120112 has been marked as a duplicate of this bug. ***

Comment 77

16 years ago
*** Bug 122343 has been marked as a duplicate of this bug. ***

Comment 78

16 years ago
I am sorry you think the battle was lost. Since aaronl (being the owner of the
keyboard navigation spec.) seems to have the last word, can we at least know
what he things about the debate? There must be a reasonable solution. 

Comment 79

16 years ago
Okay, I will comment. But let's stop flaming please. I'm open to ideas, which is
why I publish our keyboard specs on mozilla.ui and other places for comment.

The right way to do this, is that Ctrl+[shift]+tab should not only cycle through
frames in a framed web page, but when finished with the page it should move to
the next tab in tabbed browse mode. It would navigate through the superset of
frames and those tabs. For most pages, which have no frames, it would simply
move to the next tab. Believe it or not, this is actually quite difficult, but I
agree that it's desirable in the long run.

If I may ramble for a moment.

We may not always be able to make keyboard navigation for users with one hand on
the mouse, we should try. Even if we use Ctrl+[shift]+tab for switching tabs,
there is still no convenient left handed way to move back and forth in history,
as well as a host of other common commands.

A keyboard overlay, that allows single alphanumeric key presses to be used for
commands would help, plus it would be great for people who type with one hand,
or with a typing stick in their mouth. Opera and Lynx have something like that.
Their system needs to be studied, so we can implement something as good or
better for Mozilla.

We also need keyboard configurability. It's even harder to implement. There are
too many different ways that keys are specified throughout the codebase.

It would also be nice to have keyboard emulation with another browser they were
used to. I would like tooltips on buttons that tell what keystroke will activate
them. That's hard, because the buttons would need to dynamically update their
tooltips based on the current keyboard assignment.

The biggest problem with these plans is that there are very few coders in
Mozilla/Netscape that can do them right. These people are some of our top
coders. THey are often stretched very far with the other important things they
need to do. So, although we need to make plans to do the above things in the
long run, it may require patience on the part of many. 

So, why are these seemingly simple things so difficult? It might not be as much
of a problem if there was decent up-to-date documentation of our codebase, and
more willing, skilled C++ contributors, but there isn't. Sad fact is, the bowels
of our event/keyboard navigation code suck.

Anywa, back to the bug. Let's openh bug that says Ctrl+[shift]+tab should cycle
through the superset of frames and the tabs in tabbed browser mode. However, it
would be marked FUTURE unless someone else was willing to do it.

Comment 80

16 years ago
*** Bug 129331 has been marked as a duplicate of this bug. ***

Comment 81

16 years ago
*** Bug 139443 has been marked as a duplicate of this bug. ***

Comment 82

16 years ago
*** Bug 143673 has been marked as a duplicate of this bug. ***

Comment 83

15 years ago
*** Bug 183409 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.