Server error 500 if locale is set to "dsb" or "hsb"

VERIFIED FIXED

Status

Cloud Services
Server: Firefox Accounts
--
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Michael Wolf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Comment 1

3 years ago
Created attachment 8455017 [details]
Error message Sync configuration in Upper Sorbian Firfefox 31 beta 9
(Reporter)

Comment 2

3 years ago
If I go Nastroje --> Sync konfigurować... --> Prěnje kroki (Tools --> Set Up Sync... --> Get Started, I get an error message. I made a screenshot of this error message as file sync_setup_error.gif. Instead of the error message the Upper Sorbian sync registration form should be shown.

I hope you can help. On July 22 the final Firefox 31 will be released and until then this bug should be fixed.

Thanks.

PS: Seems I created an empty comment by mistake above. Please delete it.
(Reporter)

Comment 3

3 years ago
What is done for fixing this bug? Next Tuesday Upper Sorbian Firefox 31 shall be released.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Reproduced the issue using the following build:
-> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/31.0-candidates/build2/win32/hsb/

- Win XP x86 -> Reproduced
- Win XP x64 -> Reproduced
- Win Vista x86 -> Reproduced
- Win Vista x64 -> Reproduced
- Win 7 x86 -> Reproduced
- Win 7 x64 -> Reproduced
- Win 8.1 x86 -> Reproduced
- Win 8.1 x64 -> Reproduced

Can't change the status to "Confirmed" for some reason but as shown above, this occurring on all the Win OS's.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Changing subject and importance: this is not just about hsb, it's about any locale not available in the system.

If we can't have per locale fallbacks, we should at least fallback to English, not die like this.
Severity: normal → major
Summary: Upper Sorbian Firefox 31 beta 9 - Error message instead of sync form → Server error 500 if locale is not available instead of falling back to English
(Reporter)

Comment 6

3 years ago
Please let fallback to German if possible. It's just important that the functionality works. Thanks.
(Reporter)

Comment 7

3 years ago
I downloaded the stable version of yesterday from the FTP site, the issue still exists! Today is release day and in a final release all funcitionality should work. What's the real reason that this does'nt work. Firefox Accounts has been translated since months on Verbatim - I ask me why shall I translate a project if the translations don't be used resp. enabled?
This fell though the cracks in my bugmail. My apologies.

> Firefox Accounts has been translated since months on Verbatim - I ask me why shall I translate a project if the translations don't be used resp. enabled?

This is due to a configuration error with hsb in the FxA server. We're working on deploying a fix.

> Changing subject and importance: this is not just about hsb, it's about any locale not available in the system.

Unsupported locales should properly fallback to English and not die. I think this problem is limited to hsb.
Here's the PR to fix the configuration bug that caused this: https://github.com/mozilla/fxa-content-server/pull/1430/files
Correction: dsb (Lower Sorbian) is also broken, and will be resolved as part of the same fix.
QA Contact: kamiljoz
(In reply to Chris Karlof [:ckarlof] from comment #8)
> Unsupported locales should properly fallback to English and not die. I think
> this problem is limited to hsb.

You're right. I was sure I tested a random locale, but apparently I only tried hsb. If I set "intl.accept_languages" to "test", I get the English version. Amending bug subject too.
Summary: Server error 500 if locale is not available instead of falling back to English → Server error 500 if locale is set to "dsb" or "hsb"
(Reporter)

Comment 12

3 years ago
Thank you very much to you all and my best wishes!
I'm hoping to get this deployed in production sometime this afternoon (PDT).
Thanks jrgm! Sorry again for this issue falling through the cracks. If this happens again, please feel free to escalate directly to me via email or needinfo.
And by "happens again", I mean if an issue falls through the cracks again!
(Reporter)

Comment 16

3 years ago
Sorry that I ask an off-topic question here. For Upper Sorbian there are still 2 bugs with another issue: A wrong keytext key. The bugs are 1026582 and 1026990. They have already been marked as WONTFIX for Fx31 but I thought you create new builds because of this bug anyway, maybe you are able to fix the issue of the 2 mentioned bugs. For Fx 32 the key has been changed and the issue exists for Upper Sorbian Fx31 only. The solution is here: https://bugzilla.mozilla.org/show_bug.cgi?id=1026990#5

Maybe it is possible to fix this issue for Fx 31 manually.
(In reply to Michael Wolf from comment #16)
> Sorry that I ask an off-topic question here. For Upper Sorbian there are
> still 2 bugs with another issue: A wrong keytext key. The bugs are 1026582
> and 1026990. They have already been marked as WONTFIX for Fx31 but I thought
> you create new builds because of this bug anyway, maybe you are able to fix
> the issue of the 2 mentioned bugs. For Fx 32 the key has been changed and
> the issue exists for Upper Sorbian Fx31 only. The solution is here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1026990#5
> 
> Maybe it is possible to fix this issue for Fx 31 manually.

Unfortunately no, it's impossible. No builds have been created here, the issue was on Firefox Accounts server, not Firefox. Your bugs are on Firefox, and it's already released, so it can't be fixed for 31. If you want them to be fixed on 32, you need to push the changes to aurora and beta, and then to request a sign-off on Beta.
But yeah, this has nothing to do with the issue resolved here, so don't hesitate to ping :flod, :pike or me on #l10n if you have any trouble to fix them for 32.
(Reporter)

Comment 18

3 years ago
Thank you, Théo. I think, the issue does not exist for Fx 32 beta builds and Fx 33 aurora builds. It existed for Upper Sorbian Fx 31 only. Fx 31 has been released now so both bugs are resolved now, from my point of view. But I'll check this yet.
> I'm hoping to get this deployed in production sometime this afternoon (PDT).

Actually, I ran into a couple of issues with the above, and I am going to work towards just getting the next scheduled release for this out on Thursday with the fix for this. My apologies for the delay.
(Reporter)

Comment 20

3 years ago
Hello John, what is the state of affairs? I don't want to pester you but it would be good if you could solve the issues soon because I'd like to inform the public.
There is an issue with AWS (not related to this code) that is blocking the release. Ops is working to get it resolved, but I don't have an ETA.
(Reporter)

Comment 22

3 years ago
Thank you for your reply, I hope the best, although I don't know what or who AWS, Ops and ETA are. :-)
Sorry for the jargon. AWS is Amazon Web Services, Ops is our operations group, and ETA is 'estimated time of arrival'.
(Reporter)

Comment 24

3 years ago
ETA sounds as soon. ;-)
This is live in production, and hsb, lsb and sync work now. 

Thanks Michael!
I guess we can mark this as fixed then.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Also verified on a clean profile with both hsb and dsb.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 28

3 years ago
Hurra, hurra! Thank you, thank you, thank you very much that you gave this issue priority and fixed it. Now I can go public. August 3 a summer course Sorbian for Slavists and students of Slavistics will start in Lipsia and at Bautzen with international participants. They can use the Upper Sorbian or Lower Sorbian Firefox then.
You need to log in before you can comment on or make changes to this bug.