OS X Crash [@ js::GCMarker::processMarkStackOther(unsigned long, unsigned long) ]

RESOLVED DUPLICATE of bug 719114

Status

()

Core
JavaScript: GC
--
critical
RESOLVED DUPLICATE of bug 719114
4 years ago
3 years ago

People

(Reporter: Aaron Kaluszka, Unassigned)

Tracking

({crash})

Trunk
x86_64
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Looks like we are trying to scan a TypeObject that's a null pointer.
I've also ran into this today while leaving fx opened for several hours on OSX 10.9.4 and returned to the crash reporter screen. Here's my report in case it adds more context on this crash:

- bp-c26d9089-39dc-428b-9f0a-40fd32140806
I ran into this a couple of minutes ago with 33 while I was simply scrolling in a Bugzilla entry.
https://crash-stats.mozilla.com/report/index/063ab222-d96b-4215-bd21-03ccf2141013
Reproduced using Firefox 34 beta 8 while pinning and unpinning tiles on New Tab Page.

Comment 5

4 years ago
Ran into this without clear STR, Fx was running in the background (unfocused) with a just a few pages loaded including Bugzilla (and a lot unloaded tabs). 

https://crash-stats.mozilla.com/report/index/6908d305-f731-4ddf-bbc2-9ed122141123

Updated

3 years ago
Crash Signature: [@ js::GCMarker::processMarkStackOther(unsigned long, unsigned long) ] → [@ js::GCMarker::processMarkStackOther(unsigned long, unsigned long) ] [@ js::GCMarker::processMarkStackOther ]

Comment 7

3 years ago
related to bug 1077386?

(In reply to Corey Shields [:cshields] from comment #6)
> throwing my "ditto" here:
> 
> https://crash-stats.mozilla.com/report/index/52c99068-ed08-41db-83bf-
> 7d6382150117

 0 	XUL	js::GCMarker::processMarkStackOther(unsigned long, unsigned long)	js/src/jsinfer.h
1 	XUL	js::GCMarker::drainMarkStack(js::SliceBudget&)	js/src/gc/Marking.cpp
2 	XUL	js::gc::GCRuntime::incrementalCollectSlice(long long, JS::gcreason::Reason)	js/src/jsgc.cpp
3 	XUL	js::gc::GCRuntime::gcCycle(bool, long long, js::JSGCInvocationKind, JS::gcreason::Reason)	js/src/jsgc.cpp
4 	XUL	js::gc::GCRuntime::collect(bool, long long, js::JSGCInvocationKind, JS::gcreason::Reason)	js/src/jsgc.cpp
5 	XUL	js::gc::GCRuntime::notifyDidPaint()	js/src/jsgc.cpp
6 	XUL	nsXPConnect::NotifyDidPaint()	js/xpconnect/src/nsXPConnect.cpp
7 	XUL	nsRefreshDriver::Tick(long long, mozilla::TimeStamp)	layout/base/nsRefreshDriver.cpp
Keywords: crash
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 719114
You need to log in before you can comment on or make changes to this bug.