Cannot build extension for AMO from git checkout of tagged commit

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: anaran, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140713030204

Steps to reproduce:

Following instructions in
https://developer.mozilla.org/en-US/Add-ons/SDK/Tutorials/Installation#Prerequisites
to build extension for AMO from latest release tag, using
git checkout 1.16



Actual results:

Extension still gets rejected, based on

Outdated version of Add-on SDK

Warning: You are using version unknown of the Add-on SDK, which is outdated. Please upgrade to version 1.16 and repack your add-on

Root cause is that
addon-sdk/python-lib/cuddlefish/_version.py has this:

# these strings will be replaced by git during git-archive
git_refnames = "$Format:%d$"
git_full = "$Format:%H$"

I can see the value of using git-archive as part of the release process.


Expected results:

Would it be feasible to expand these values for tagged official releases of the addon-sdk?

This would probably mean another commit with just the values expanded in addon-sdk/python-lib/cuddlefish/_version.py after all the testing of the release has been done.
(Reporter)

Comment 1

5 years ago
I found a fairly simple solution:

git checkout 1.16
git archive 1.16 python-lib/cuddlefish/_version.py | tar -xvf -

and have updated 
https://developer.mozilla.org/en-US/Add-ons/SDK/Tutorials/Installation#Prerequisites
accordingly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.