[prod][traceback] 500 error: TypeError: login_failure() takes exactly 1 argument (2 given)

VERIFIED DUPLICATE of bug 1038055

Status

Participation Infrastructure
Phonebook
--
major
VERIFIED DUPLICATE of bug 1038055
4 years ago
4 years ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Details

(Whiteboard: [prod])

(Reporter)

Description

4 years ago
I'm not sure how to reproduce this, however we get several dozen tracebacks per week with this signature.


Traceback (most recent call last):

  File "/data/www/mozillians.org/mozillians/vendor/lib/python/django/core/handlers/base.py", line 113, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-2.16.0.12/newrelic/hooks/framework_django.py", line 492, in wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/mozillians.org/mozillians/vendor/lib/python/django/views/generic/base.py", line 68, in view
    return self.dispatch(request, *args, **kwargs)

  File "/data/www/mozillians.org/mozillians/vendor-local/src/django-browserid/django_browserid/views.py", line 97, in dispatch
    return super(Verify, self).dispatch(request, *args, **kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-2.16.0.12/newrelic/hooks/framework_django.py", line 829, in wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/mozillians.org/mozillians/vendor/lib/python/django/views/generic/base.py", line 86, in dispatch
    return handler(request, *args, **kwargs)

  File "/data/www/mozillians.org/mozillians/mozillians/common/authbackend.py", line 70, in post
    return super(BrowserIDVerify, self).post(*args, **kwargs)

  File "/data/www/mozillians.org/mozillians/vendor-local/src/django-browserid/django_browserid/views.py", line 85, in post
    return self.login_failure(e)

TypeError: login_failure() takes exactly 1 argument (2 given)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1038055
(Reporter)

Comment 2

4 years ago
\o/ verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.