Hit testing doesn't work correctly.

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: bijan, Assigned: tschneider)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8455497 [details]
TheLineGameFinished.fla

The car should stop when it's off the track.
Fixed by https://github.com/mozilla/shumway/commit/93e379e0978c07b83df9f5921441f43ebb625428

Sorry about regressing that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Created attachment 8473492 [details]
acid-click-0.fla
Clicking on the lighter colored part of the shape does not work. Normally a shape like this is composed of two disjoint paths. In this case, I *think* the IDE generates two overlapping paths because of the way the SWF was authored. The hit testing algorithm probably thinks the point is outside, since it is inside of two paths.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Blocks: 1037568
(Assignee)

Updated

4 years ago
Assignee: nobody → schneider
(Assignee)

Comment 4

4 years ago
I think we just have to return earlier whenever we start a new sub-shape (which happens when the fill/line style changes) and the hit-test is already positive at that point.
(Assignee)

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.