Refactor VideoCaptureImpl & DesktopCaptureImpl to better share code

NEW
Unassigned

Status

()

Core
WebRTC
4 years ago
3 years ago

People

(Reporter: m_and_m, Unassigned)

Tracking

unspecified
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
DesktopCaptureImpl and VideoCaptureImpl use the same code for various functions (e.g., ::IncomingFrame()).  The current re-use is copy-paste from VideoCaptureImpl to DesktopCaptureImpl, but there should be a better abstraction to reduce code duplication.
backlog: --- → parking-lot
You need to log in before you can comment on or make changes to this bug.