If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent 408431-1.html | application crashed [@ sipcc::PeerConnectionImpl::SetDtlsConnected(bool)]

RESOLVED DUPLICATE of bug 1048261

Status

()

Core
WebRTC: Networking
RESOLVED DUPLICATE of bug 1048261
3 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
ARM
Android
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=43756689&tree=Fx-Team

Android 2.3 Armv6 Emulator fx-team opt test crashtest-1 on 2014-07-14 09:59:02 PDT for push fc0750213b61
slave: talos-linux64-ix-041

10:15:17     INFO -  REFTEST TEST-START | http://10.0.2.2:8854/tests/dom/src/offline/crashtests/408431-1.html
10:15:17     INFO -  RESTORE PREFERENCE pref(media.navigator.permission.disabled,false)
10:15:17     INFO -  REFTEST TEST-LOAD | http://10.0.2.2:8854/tests/dom/src/offline/crashtests/408431-1.html | 663 / 1376 (48%)
10:15:17     INFO -  
10:15:17     INFO -  INFO | automation.py | Application ran for: 0:11:33.565791
10:15:17     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpUpoIIdpidlog
10:15:17     INFO -  Contents of /data/anr/traces.txt:
10:15:17     INFO -  
10:15:17     INFO -  
10:15:17     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/fx-team-android-armv6/1405355648/fennec-33.0a1.en-US.android-arm-armv6.crashreporter-symbols.zip
10:15:17  WARNING -  PROCESS-CRASH | http://10.0.2.2:8854/tests/dom/src/offline/crashtests/408431-1.html | application crashed [@ sipcc::PeerConnectionImpl::SetDtlsConnected(bool)]
10:15:17     INFO -  Crash dump filename: /tmp/tmprNJeij/2dd87412-606d-62d7-5a4649d6-69135cf8.dmp
10:15:17     INFO -  Operating system: Android
10:15:17     INFO -                    0.0.0 Linux 2.6.29-ge3d684d #1 Mon Dec 16 22:26:51 UTC 2013 armv7l generic/sdk/generic:2.3.7/GINGERBREAD/eng.ubuntu.20140123.014351:eng/test-keys
10:15:17     INFO -  CPU: arm
10:15:17     INFO -       0 CPUs
10:15:17     INFO -  
10:15:17     INFO -  Crash reason:  SIGSEGV
10:15:17     INFO -  Crash address: 0x8
10:15:17     INFO -  
10:15:17     INFO -  Thread 11 (crashed)
10:15:17     INFO -   0  libxul.so!sipcc::PeerConnectionImpl::SetDtlsConnected(bool) [nsCOMPtr.h:fc0750213b61 : 815 + 0x4]
10:15:17     INFO -       r4 = 0x533ec580    r5 = 0x00000000    r6 = 0x473ff834    r7 = 0x473ff86f
10:15:17     INFO -       r8 = 0x46f02274    r9 = 0x00000000   r10 = 0x00000001    fp = 0x00000000
10:15:17     INFO -       sp = 0x473ff800    lr = 0x4c8a4e4c    pc = 0x4c8a4e78
10:15:17     INFO -      Found by: given as instruction pointer in context
10:15:17     INFO -   1  libxul.so!mozilla::runnable_args_m_1<sipcc::PeerConnectionImpl*, tag_nsresult (sipcc::PeerConnectionImpl::*)(bool), bool>::Run() [runnable_utils_generated.h:fc0750213b61 : 122 + 0x26]
10:15:17     INFO -       r4 = 0x46f02240    r5 = 0x00000000    r6 = 0x473ff834    r7 = 0x473ff86f
10:15:17     INFO -       r8 = 0x46f02274    r9 = 0x00000000   r10 = 0x00000001    fp = 0x00000000
10:15:17     INFO -       sp = 0x473ff818    pc = 0x4c8abc24
10:15:17     INFO -      Found by: call frame info
10:15:17     INFO -   2  libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:fc0750213b61 : 766 + 0xa]
10:15:17     INFO -       r4 = 0x46f02240    r5 = 0x00000000    r6 = 0x473ff834    r7 = 0x473ff86f
10:15:17     INFO -       r8 = 0x46f02274    r9 = 0x00000000   r10 = 0x00000001    fp = 0x00000000
10:15:17     INFO -       sp = 0x473ff820    pc = 0x4c49943c
10:15:17     INFO -      Found by: call frame info
10:15:17     INFO -   3  libxul.so!NS_ProcessNextEvent(nsIThread*, bool) [nsThreadUtils.cpp:fc0750213b61 : 256 + 0x12]
10:15:17     INFO -       r4 = 0x00000000    r5 = 0x46f5c0c0    r6 = 0x00000001    r7 = 0x4e47f900
10:15:17     INFO -       r8 = 0x46f49080    r9 = 0x00000021   r10 = 0x473ff8f0    fp = 0x0000000f
10:15:17     INFO -       sp = 0x473ff868    pc = 0x4c44ec90
10:15:17     INFO -      Found by: call frame info
10:15:17     INFO -   4  libxul.so!mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) [MessagePump.cpp:fc0750213b61 : 99 + 0xa]
10:15:17     INFO -       r4 = 0x46f49070    r5 = 0x46f5c0c0    r6 = 0x00000001    r7 = 0x4e47f900
10:15:17     INFO -       r8 = 0x46f49080    r9 = 0x00000021   r10 = 0x473ff8f0    fp = 0x0000000f
10:15:17     INFO -       sp = 0x473ff878    pc = 0x4c66f548
10:15:17     INFO -      Found by: call frame info
10:15:17     INFO -   5  libxul.so!MessageLoop::RunInternal() [message_loop.cc:fc0750213b61 : 229 + 0xa]
10:15:17     INFO -       r4 = 0x46f5c0c0    r5 = 0x46f3e7d0    r6 = 0x46f02240    r7 = 0x473ffac5
10:15:17     INFO -       r8 = 0x473ff900    r9 = 0x00000021   r10 = 0x473ff8f0    fp = 0x0000000f
10:15:17     INFO -       sp = 0x473ff8a0    pc = 0x4c65e478
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 4

3 years ago
This is probably a dupe of bug 1048261

Comment 5

2 years ago
No occurrences since bug 1048261 landed, marking as a dupe.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048261
You need to log in before you can comment on or make changes to this bug.