can't move multiple messages in local folders

VERIFIED WORKSFORME

Status

MailNews Core
Backend
--
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Marko Macek, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 2001100803 and NS6.1 (every recent build I tried)

I cannot move more than one message at once between two folders in "Local
Folders"  hierarchy. Moving a single message at the time works fine.

It looks like the problem is happening because I moved my Local Folders to
another drive (outside of the profile) and set the appropriate directory in the
"Local Folders" account settings.

Updated

17 years ago
QA Contact: esther → sheelar

Comment 1

17 years ago
reassign
Assignee: mscott → naving

Comment 2

17 years ago
commercial branch build: 0.9.4-2001-10-09-05 win98. I am able to move multiple 
messages between two local folders.  I did change my local folders directory to 
a different drive and it works for me.  
Reporter,
Can you delete the .msf file of the folder that you are trying to move the 
message to  and see if multiple move works again.  Also restart the application 
and let it build the summary file and see if it fixes the problem.  

Comment 3

17 years ago
I think the user is saying he tried to move local messages across two
hierarchies, i.e., between his pop3 account local folders, and a local folders
account. We might be treating this as a cross-server move, when we shouldn't.

Comment 4

17 years ago
I was not allowed to drag drop single or multiple messages across local folder
hierarchies (which is itself a bug). The drag drop cursor wouldn't let me.

Comment 5

17 years ago
but using the move/copy menu item worked fine for multiple messages.
(Reporter)

Comment 6

17 years ago
I have created two new mail folders and 2 new messages inside one of them.

If I point "local folders" to c:\mozilla\profiles\... and copy the 2 folders
(with explorer) there, I can easily move the 2 messages between them.

If I point "local folders" to e:\work\mailLocal and move (with explorer, outside
of mozilla), I can't move the 2 messages at once. Either with drag-drop or "Move
To" context menu option.

There is no problem with drag-drop cursor.
I tried running mozilla -console, but there are no error messages.

I have also moved my pop3 server folders to e:\work\mail and I can move messages
in those folders just fine. I can also move multiple messages pop3->local.

I can't move multiple msgs inside "local folders" or local->pop3 folders.
(Reporter)

Comment 7

17 years ago
I have also tried pointing "local folders" to the same drive (c:\work\mail) and
it works fine. But in e:\work\mail it doesn't (I tried a brand new empty
directory and created 2 new folders there).

Comment 8

17 years ago
reporter,
Are you seeing this problem on recent builds? 
I am seeing this problem on Linux - I am unable to drag multiple messages from
Drafts or Sent to any of my IMAP folders (which are remote.) Single messages
work fine. The symptoms are that the spinner in the status bar spins
indefinitely but nothing happens.

Moreover, after the failure, single drag-drop stops working until I restart
Mozilla. This is really quite serious. This may be a local symptom of a more
severe bug, where _everything_ stops working after a while.

Gerv
Keywords: mozilla1.0
OS: Windows 2000 → All

Comment 10

17 years ago
gervase, are your drafts or sent folder local, or on a different imap server? I
was able to copy 12 local messages into an imap folder, no problem.
My drafts and sent folder are local. I filed a more detailed bug, with an IMAP
log, over in bug 129928.

Gerv

Comment 12

16 years ago
I observed that the "move to folder" function seizes to work after a number of
move operations. The limiting number was 3 or 5 or so. Since RC2 (maybe earlier)
the problem didn't re-appear, until today when I moved lots of messages, so the
problem is still there but the limit is higher now. The effect is not permanent
insofar as it is gone when you restart mozilla. The effect is the same for
drag&drop and for the "Move To" item from the mail header context menu. Using
build 2002052008 on WinNT, with 8 POP3 accounts.

Comment 13

16 years ago
Hans, are you strictly moving mail between local accounts? (Gerv, I don't want
to confuse any IMAP issues with any strictly local mail issues). Marko, are you
seeing this with any recent builds? I tried setting up my local folders account
on a different logical drive and didn't have any problems, and I can't think why
it would matter.

Comment 14

16 years ago
The last time I saw this I was moving messages from one of my inboxes to a
sub-sub-subfolder of "Local Folders". All my local mail folders are in the same
directory tree. As I mentioned earlies, I have only POP3 accounts, so the move
was done from a local folder to a local folder.
(Reporter)

Comment 15

16 years ago
It now seems to work fine for me with 1.0rc3. Resolve as fixed/worksforme?

Comment 16

16 years ago
Marking this bug as worksforme since the initial reporter does not have problem
with the recent builds.  Refer to 129928 for problem while moving multiple
messages from imap account.  

If you see problems with moving multiple messages in recent builds please reopen
the bug.  
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 17

16 years ago
Verifying this as worksforme.
Status: RESOLVED → VERIFIED

Comment 18

16 years ago
Replying to comment #13: I read some documents that indicated that my proxy has
problems with its cache. I disabled caching, and will report back only if I ever
encounter the problem again.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.