Closed Bug 10384 Opened 21 years ago Closed 20 years ago

invalid host specified: the request did not specify a valid virtual host

Categories

(Core :: Networking, defect, P3, critical)

x86
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: jdaly, Assigned: jud)

References

()

Details

this problem appears to happen with the oracle web server (spyglass)

this webserver requires that the url hostname sent by the browser match the one
defined in the configuration file.

this page should bring up a password dialog -- instead it bring up an error that
would happen if the hostname is sent incorrectly, for example
http://207.15.160.14:8888/ would bring up this same error.

this does not appear to be a problem with this webserver if there is no port
specification (for example http://www.lastminutetravel.com/ vs
http://lastminutetravel.com/).
Assignee: gagan → valeski
Doesn't this have to do with the DNS entry that you have setup for the host? Jud
you mentioned something about this... assigning for your comments.
I'm confused. You state:
"this does not appear to be a problem with this webserver if there is no port
specification (for example http://www.lastminutetravel.com/ vs
http://lastminutetravel.com/)."

there is no port specification on either of these. do you mean host
specification (i.e. no "www")?
Severity: blocker → critical
this is not a blocker that I am aware of. A blocker is a bug that prevents other
parts of the browser from being tested or developed on.
sorry for the confusion, let me clarify a little...

the spyglass webserver (used with oracle webserver) requires that a valid
virtual hostname be used from the browser.

if the hostname specified in the webserver configuration is
www.lastminutetravel.com, any other variation on hostname, even if it resolves
to the same ip address, won't work (e.g., http://www.lastminutetravel.com/ works
vs. http://lastminutetravel.com/ which doesn't).

an exaple of this that -doesn't- work with mozilla is when the url has a port
specification. for example on netscape the page http://www.ticketpay.com:7819/
works correctly (it brings up a password dialog) because it is using a valid
virtual host (www.ticketpay.com and ticketpay.com are specified in the
configuration file for this listener). trying the same url in mozilla fails with
an 'invalid virtual host' type error.

to summarize, in mozilla the hostname seems to be sent correctly if there is no
port specified, otherwise, something funky is happening.

i also tried http://www.lastminutetravel.com:80/ on mozilla, and this appears to
work correctly for some reason?
Target Milestone: M14
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I think this was a redirect problem. lastminutetravel.com and www.last...com
work fine for me. http://www.ticketpay.com:7819/ doesn't do anything in either
browser.
Status: RESOLVED → VERIFIED
looks good
You need to log in before you can comment on or make changes to this bug.