If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

double click on system tray icon de-maximises open window

VERIFIED FIXED in mozilla0.9.6

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
VERIFIED FIXED
16 years ago
5 years ago

People

(Reporter: Robert Pollak, Assigned: Bill Law)

Tracking

Trunk
mozilla0.9.6
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When I have one mozilla window open and maximised, double clicking on the tray
icon makes the window come to front (which is ok) and makes it lose the
maximization.
Expected: The window stays maximised.
I see this with a browser or a mail window, haven't looked at other task's
windows yet.
(Reporter)

Comment 1

16 years ago
This is with build 2001100803.

Comment 2

16 years ago
reproduced- Windows 2000 build 2001100903
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 3

16 years ago
Created attachment 53296 [details] [diff] [review]
Test ::IsIconic before calling ::ShowWindow( ..., SW_RESTORE )

Updated

16 years ago
Attachment #53296 - Flags: review+

Comment 4

16 years ago
Comment on attachment 53296 [details] [diff] [review]
Test ::IsIconic before calling ::ShowWindow( ..., SW_RESTORE )

sr=blake
Attachment #53296 - Flags: superreview+
(Assignee)

Comment 5

16 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 6

16 years ago
*** Bug 99856 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Note that OpenIcon, which I'd never noticed until just now, would also work in
place of ShowWindow(SW_RESTORE).

"The OpenIcon function restores a minimized (iconic) window to its previous size
and position; it then activates the window."

Comment 8

16 years ago
verified on build 2001102903 Win2000 and WinNT
Status: RESOLVED → VERIFIED
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.