some dialogs are clipped at the bottom

VERIFIED FIXED in mozilla0.9.6

Status

P1
blocker
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: ssaux, Assigned: jag-mozilla)

Tracking

({regression})

Trunk
mozilla0.9.6
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
In the 10/05 build the enter master password dialog was fine.
In the 10/08 build the text wraps,which causes the buttons to be cropped.
I'm attaching two screenshots.
Note that PSM code (including code for this dialog) has not changed in weeks.
(Reporter)

Updated

17 years ago
Keywords: nsbranch, regression
Priority: -- → P1
Target Milestone: --- → 2.1
(Reporter)

Comment 1

17 years ago
Created attachment 52725 [details]
dialog as it appeared on 10/05
(Reporter)

Comment 2

17 years ago
Created attachment 52726 [details]
dialog on 10/08  branch build

Comment 3

17 years ago
Created attachment 52727 [details]
Simple MAPI dialog confirmation is also broken

Comment 4

17 years ago
Created attachment 52728 [details]
http basic auth dialog clipped

Comment 5

17 years ago
Changing title to reflect the general nature of the problem.  
Changing component to Browser for triage.
Component: Client Library → User Interface Design
Product: PSM → Browser
Summary: regression on master password dialog: size is wrong, buttons are cropped → some dialogs are clipped at the bottom
Target Milestone: 2.1 → M1
Version: 2.1 → other

Comment 6

17 years ago
Adding PDT to the status whiteboard to raise the visibility of this bug. I am
seeing this as well. (I'll try to add screen shots as I encounter clipped dialog
boxes.) This is a visible regression that makes the application look very
unpolished.

The dialogs appear to function correctly. They cannot, however, be resized to
eliminate the clipping at the bottom.
Whiteboard: pdt

Updated

17 years ago
Whiteboard: pdt → [PDT]

Comment 7

17 years ago
Some dialogs that are *not* clipped include the "Would you like Netscape 6 to be
your default browser" dialog, and the mail server password dialog.

Not sure why the difference.

Comment 8

17 years ago
This will be particularly bad in European languages that will take more space
than English does, making the clipping even worse. I vote for fixing this in the
release

Comment 9

17 years ago
this looks like a XUL issue, that we need to resolve pretty quickly for 094.

--> hyatt
Assignee: ssaux → hyatt

Updated

17 years ago
Blocks: 103693

Comment 10

17 years ago
nsbranch+ 096
No longer blocks: 103693
Keywords: nsbranch → nsbranch+
Target Milestone: M1 → mozilla0.9.6

Comment 11

17 years ago
--> jag, who may know what went into the branch that shouldn't have.
Assignee: hyatt → jaggernaut
(Assignee)

Comment 12

17 years ago
Created attachment 52770 [details] [diff] [review]
Back out bogus sizeToContent
(Assignee)

Comment 13

17 years ago
Comment on attachment 52770 [details] [diff] [review]
Back out bogus sizeToContent

sr= by hyatt
Attachment #52770 - Flags: superreview+

Updated

17 years ago
Attachment #52770 - Flags: review+

Comment 14

17 years ago
Comment on attachment 52770 [details] [diff] [review]
Back out bogus sizeToContent

r=alecf

Comment 15

17 years ago
is this size to content fix needed for another bug so we may need to reopen
another bug?
(Assignee)

Comment 16

17 years ago
I own the other bug and it's still open: bug 92635.

Comment 17

17 years ago
It's open because it is not checked into the Trunk, not because it has not been
checked into the 094 branch, right?
(Assignee)

Comment 18

17 years ago
Right. As a matter of fact, it was only checked into the 0.9.4 branch. I will
try to come up with a different "hack" for that bug, but I'd say we take this
partial back-out (the other part of the checkin was valid) to fix this way more
visible bug.

Comment 19

17 years ago
*** Bug 103693 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 20

17 years ago
Waiting for PDT+ to check this in.

Comment 21

17 years ago
pls check this in to the branch 
= PDT+
Whiteboard: [PDT] → [PDT+]
(Assignee)

Comment 22

17 years ago
Checked in, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 23

17 years ago
Created attachment 52840 [details]
Send Message dialog also clipped.(should be fixed in the branch too)

Comment 24

17 years ago
*** Bug 103982 has been marked as a duplicate of this bug. ***

Comment 25

17 years ago
Verified on 10/10 WinNT branch build. I can't find any more clipped dialog 
boxes. Please file a new bug for specificd dialog boxes if you find any.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.