bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Opening an attachment received fails to open installed app.



MailNews Core
17 years ago
7 years ago


(Reporter: Stephane Saux, Unassigned)


Windows 2000

Firefox Tracking Flags

(Not tracked)



(7 attachments)



17 years ago
When I double click on the attachment, I get a dialog asking me whether I want
to open it using excel, or save it to disk.
I chose to open it using excel, and what I got was the same dialog, but the
excel part was not recognized anymore, and the document was not opened.

Comment 1

17 years ago
Created attachment 52730 [details]
second dialog I go when trying to open attachment using excell


17 years ago
Whiteboard: pdt

Comment 2

17 years ago

Please can you try to repro this? Thx.

Comment 3

17 years ago
Marking P3, since many tests of sending and opening EXCEL attachment has been 
Priority: -- → P3

Comment 4

17 years ago
Created attachment 52918 [details]
screenshot of dialog resulting from double clicking on the email sent from s/mapi

Comment 5

17 years ago
Here are the steps to reproduce:
Open an excel document.
select file->send to->email recipient.
Send it to yourself (using n6)
go to your inbox.
open the message.
Double click on the attachment.
The dialog attached above shows up.

Comment 6

17 years ago
TianTian - should find out which version of Excel is at fault here.

Stephane - which version of Excel do you have?  I'm going to send you an excel
spreadsheet.  Are you able to double click on it to launch/open the spreadsheet
in excel?   If yes, save this file to your system.  Then, open it in Excel and
try to send it via MAPI to me and to yourself.  See if it launches again from
the mail msg.
Keywords: nsbranch

Comment 7

17 years ago
Created attachment 53136 [details]
My version of excel

Comment 8

17 years ago
Created attachment 53137 [details]
Dialog resulting from double clicking on excel doc attached to Lisa Chiang's email to me.

Comment 9

17 years ago
Created attachment 53139 [details]
attachement pane from Lisa Chiang's email

Comment 10

17 years ago
Created attachment 53140 [details]
attachment pane from sending the same attachment after opening it from a manually selected application.

Comment 11

17 years ago
I think it's ok to have the dialog come up.  We don't automatically launch
Excel.  I believe this was the behavior as in 6.1.  In all of the attachments I
sent to Stephane, simple mapi was not involved.   I will forward to Esther to
take a look at Stephane's system.

Comment 12

17 years ago
Stephane - if you simply send yourself an Excel spreadsheet attached to an email
message, and then retrieve the message and double click on the attachment, do
you see the same dialogs as above? In other words, is this a Simple MAPI
problem, or an attachment handling problem?

Comment 13

17 years ago
Stephane, were you able to open Excel attachments using Netscape 6 before this
or was this the first time you tried.  From your original scenaio, you say it
asked if you wanted to open it using Excel.  Where was Excel mentioned?  If you
had already chosen Excel as the app throught migration or the Choose button, it
would have been mentioned in the radio button description "Open using EXCEL.EXE"
and that would have been the button selected by default.  If you hadn't set it
up then the default radio button selected would have been "Save this file to
Disk".  At that point selecting Open, then "Choose" would have asked for the
location of Excel.   

Comment 14

17 years ago
It may very well be a problem with attachment in general.  I'm able to open some
correctly and other I can't.


17 years ago
Whiteboard: pdt → [PDT] [Need ETA]

Comment 15

17 years ago
Stephane, I would like to stop by to see the attachment/attachments that fail to
open the associated windows app.  I'll call you.

Comment 16

17 years ago
We think this is an attachment issue, isolated to Stephane undertsanding on how
this is suppose to work = PDT-
Whiteboard: [PDT] [Need ETA] → [PDT-] [Need ETA]

Comment 17

17 years ago
Stephane - I can open the attachment you sent me and one I sent myself.  The
attachments sent by me with Excel97 have (Content Type: application/octet-stream:
name="potentialbug.XLS").   The attachment I received from you had (Content
Type: application/vnd.ms-excel; name="RootCAinfo.XLS").  Both types of
attachment gave me the default action to Open with EXCEL and worked.  In trying
to figure out why yours didn't work I edited my File type associations in
Explorer.  That's when I fail at recognizing the application/vnd.ms-excel file.
To trouble shoot I would like check out your Preference Setting for
Navigator|Helper Apps.  If you could attach a snapshot of this, then I can
determine if I need to check your Explorer File Type associations.  

Comment 18

17 years ago
Also note: attachment 53140 [details] in this bug is the correct behavior.  If the user
opens a excel attachment, it opens with a randomly generated name. If user then
that opened excel attachment it will save with the random name.  This is by
design, I'll find the bug that states this.

Comment 19

17 years ago
opening an excel or word doc does generate a random file name, that is
duplicatible, but saving the document saves the actual filename, both by
selecting "Save this to disk" option from the dialog box or by right mouse
clicking the attachment.  this was using 97 & 00 office on various OS's.

But this is not a Simple MAPI bug, since sending an attachment from Netscape
Mail  displays the same results.

Comment 20

17 years ago
Trix, to make clear my comment regarding attachment 53140 [details] in case someone was
thinking this was a bug.  Note: from a mail msg attachment area, Open the
document generates a new name for the document when opened.  From a mail msg
attachment area, Save As...keeps the original name when saving.
If the user (Stephane did this), opens the document, then does a Send to from
the MS App, they will see the new name for the documnent in the attachment area
of the newly sent message. This is not a bug, but by design.

Comment 21

17 years ago
I checked my application mapping, and for application/vnd.ms-excel I had
"Application" checked by the application was empty.  I've manually updated my
profile to open documents of this mime type using excel.

Comment 22

17 years ago
Stephane, where did you check your application mapping?  From our
Preference|Navigator|Helper Applications?   Or through the Advance Button in the
Dialog for downloading (as seen in your first screenshot).  If
"application/vnd.ms-excel" listed in the Navigator preference under Helper
Applications, I was told by the developer, the user didn't need to add that
association via the Advance button on the Downloading dialog, if Excel is
installed on the system.   We may still have a problem, but for now, can you
tell me if it works for you after adding it manually.  Taking Simple MAPI out of
the description, not a Simple MAPI issue.  Changine QA and Assigned to
Assignee: tiantian → mscott
QA Contact: trix → esther
Summary: Opening an attachment received via Simple Mapi fails. → Opening an attachment received fails to open installed app.


17 years ago
Component: Simple MAPI → Mail Back End

Comment 23

17 years ago
Esther, Scott,
  When you earlier asked me to check the help apps mapping, I changed the
mapping in prefs->navigator->helper apps to have the full path to excel appear
in the
  After doing so, when I double click on an Excel attachment, it works as expected.
  I also then removed the path I had entered in the pref and it reverted to
detecting the attachment type properly, and yet not being able to find the excel
  I then restored the manual mapping I had added to my prefs->navigator->help
apps and it works anew.

Hope this helps. Could be a weirdness in my system.

Comment 24

17 years ago
Created attachment 54075 [details]
Edit type window for the Excel type (prefs->nav->helper apps->edit)

Comment 25

17 years ago
The previous attachment shows how it is now (Makes it possible for me to open
all Excel attachments)  When it doesn't work the application radio button is
checked, but the value is empty.

Comment 26

17 years ago
Hey Stephane, thanks for experimenting with this. The "normal" user scenario for
excel should have been the following: 
1) we properly detect the mime type and show you the excel icon (works for you too)
2) when you try to open the attachment up, we sniff your windows registry to see
if excel registered itself as the application for vnd.msexcel, we discover that
excel is registered. The helper app dialog comes up with "Excel" listed under
the radio button for open attachment. User hits enter, we send the file to the
OS asking it to open the file, the OS fires up word. No user intervention
required. No need to find the path to excel, etc.

Sounds like the last part of step 2 is failing on your system. When we send the
file to the OS to be launched, excel isn't properly launching.

Can you run 'regedit' and then look up your mime type entry for excel. it should
.xls is the key
Can you find the values for the ShellEx component of the .xls entry? 


17 years ago
Blocks: 107065


17 years ago
Keywords: nsbranch


16 years ago
QA Contact: esther → trix

Comment 27

16 years ago
nomianting, so we take another look at this one.
Severity: normal → major
Keywords: nsbeta1
Whiteboard: [PDT-] [Need ETA]


16 years ago
Keywords: nsbeta1 → nsbeta1-

Comment 28

16 years ago
There was no comment, when this bug was marked nsbeta1. Is it because this is an
isolated case that can't be reproduced, or ...?
QA Contact: trix → stephend
Product: MailNews → Core

Comment 29

11 years ago
I would like to verify this bug. Running Thunderbird 1.5 On Ubuntu 6.06 Dapper. Cannot open openoffice associated (.odt, .doc) documents if openoffice is already open. Cannot open PDF files at all. Only work around is to save to desktop and then open.


10 years ago
Assignee: mscott → nobody
QA Contact: stephend → backend


10 years ago
Product: Core → MailNews Core

Comment 30

7 years ago
no testcase and reporters' addresses are dead
=> incomplete
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.