Intermittent memory.js | application crashed [@ js::jit::MacroAssembler::PopRegsInMaskIgnore(js::jit::RegisterSet, js::jit::RegisterSet)] | Assertion failure: diffF == 0, at /builds/slave/m-in-and-d-0000000000000000000/build/js/src/jit/arm/MacroAssembler-

RESOLVED DUPLICATE of bug 1039207

Status

()

Core
JavaScript Engine: JIT
RESOLVED DUPLICATE of bug 1039207
4 years ago
3 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({assertion, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Android 4.0 Panda mozilla-inbound debug test jsreftest-1 on 2014-07-15 02:55:28 PDT for push f1a8a13674dd

slave: panda-0100

https://tbpl.mozilla.org/php/getParsedLog.php?id=43813110&tree=Mozilla-Inbound

Assertion failure: diffF == 0, at /builds/slave/m-in-and-d-0000000000000000000/build/js/src/jit/arm/MacroAssembler-arm.cpp:1928

03:26:15  WARNING -  PROCESS-CRASH | http://10.26.128.18:30100/jsreftest/tests/jsreftest.html?test=ecma_6/TypedObject/memory.js | application crashed [@ js::jit::MacroAssembler::PopRegsInMaskIgnore(js::jit::RegisterSet, js::jit::RegisterSet)]
03:26:15     INFO -  Crash dump filename: /tmp/tmp1sI0a7/322a1457-508d-2fad-15b97b3c-480a4e78.dmp
03:26:15     INFO -  Operating system: Android
03:26:15     INFO -                    0.0.0 Linux 3.2.0+ #2 SMP PREEMPT Thu Nov 29 08:06:57 EST 2012 armv7l pandaboard/pandaboard/pandaboard:4.0.4/IMM76I/5:eng/test-keys
03:26:15     INFO -  CPU: arm
03:26:15     INFO -       2 CPUs
03:26:15     INFO -  Crash reason:  SIGSEGV
03:26:15     INFO -  Crash address: 0x0
03:26:15     INFO -  Thread 30 (crashed)
03:26:15     INFO -   0  libxul.so!js::jit::MacroAssembler::PopRegsInMaskIgnore(js::jit::RegisterSet, js::jit::RegisterSet) [Architecture-arm.h:f1a8a13674dd : 407 + 0x8]
03:26:15     INFO -       r4 = 0x00000002    r5 = 0x00000000    r6 = 0x00000004    r7 = 0x00000004
03:26:15     INFO -       r8 = 0xfffffffc    r9 = 0x00000000   r10 = 0x00000001    fp = 0x00000004
03:26:15     INFO -       sp = 0x6747fcb0    lr = 0x633fbdb9    pc = 0x6342de14
03:26:15     INFO -      Found by: given as instruction pointer in context
03:26:15     INFO -   1  libxul.so!js::jit::CodeGeneratorShared::restoreLiveIgnore(js::jit::LInstruction*, js::jit::RegisterSet) [CodeGenerator-shared-inl.h:f1a8a13674dd : 164 + 0x3]
03:26:15     INFO -       r4 = 0x704081d0    r5 = 0x6747fd88    r6 = 0x00000002    r7 = 0x00000006
03:26:15     INFO -       r8 = 0x00000000    r9 = 0x00000004   r10 = 0x00000000    fp = 0x00003fff
03:26:15     INFO -       sp = 0x6747fd48    pc = 0x6330a663
03:26:15     INFO -      Found by: call frame info
03:26:15     INFO -   2  libxul.so!bool js::jit::CodeGeneratorShared::visitOutOfLineCallVM<js::jit::ArgSeq<js::jit::ArgSeq<void, void>, js::jit::Register>, js::jit::StoreFloatRegisterTo>(js::jit::OutOfLineCallVM<js::jit::ArgSeq<js::jit::ArgSeq<void, void>, js::jit::Register>, js::jit::StoreFloatRegisterTo>*) [CodeGenerator-shared.h:f1a8a13674dd : 744 + 0x9]
03:26:15     INFO -       r4 = 0x00000000    r5 = 0x00000000    r6 = 0x71c5b568    r7 = 0x6b359000
03:26:15     INFO -       r8 = 0x704080d8    r9 = 0x6b35a880   r10 = 0x00000000    fp = 0x00003fff
03:26:15     INFO -       sp = 0x6747fd88    pc = 0x63367b7b
03:26:15     INFO -      Found by: call frame info
03:26:15     INFO -   3  libxul.so!js::jit::OutOfLineCodeBase<js::jit::CodeGenerator>::generate(js::jit::CodeGeneratorShared*) [CodeGenerator-shared.h:f1a8a13674dd : 541 + 0x5]
03:26:15     INFO -       r4 = 0x6b359000    r5 = 0x00000125    r6 = 0x6b35ab00    r7 = 0x6b35a880
03:26:15     INFO -       r8 = 0x6b35a894    r9 = 0x6b35ab08   r10 = 0x00000494    fp = 0x00003fff
03:26:15     INFO -       sp = 0x6747fdb8    pc = 0x632ef9b1
03:26:15     INFO -      Found by: call frame info
03:26:15     INFO -   4  libxul.so!js::jit::CodeGeneratorShared::generateOutOfLineCode() [CodeGenerator-shared.cpp:f1a8a13674dd : 103 + 0x9]
03:26:15     INFO -       r4 = 0x6b359000    r5 = 0x00000125    r6 = 0x6b35ab00    r7 = 0x6b35a880
03:26:15     INFO -       r8 = 0x6b35a894    r9 = 0x6b35ab08   r10 = 0x00000494    fp = 0x00003fff
03:26:15     INFO -       sp = 0x6747fdc0    pc = 0x63433ca1
03:26:15     INFO -      Found by: call frame info
03:26:15     INFO -   5  libxul.so!js::jit::CodeGeneratorARM::generateOutOfLineCode() [CodeGenerator-arm.cpp:f1a8a13674dd : 171 + 0x3]
03:26:15     INFO -       r4 = 0x6b359000    r5 = 0x6b359000    r6 = 0x6b35a9c0    r7 = 0x6b35ab48
03:26:15     INFO -       r8 = 0x6f9ec1b0    r9 = 0x6411cc10   r10 = 0x000000d0    fp = 0x6411cc10
03:26:15     INFO -       sp = 0x6747fdf8    pc = 0x63433def
03:26:15     INFO -      Found by: call frame info
03:26:15     INFO -   6  libxul.so!js::jit::CodeGenerator::generate() [CodeGenerator.cpp:f1a8a13674dd : 6602 + 0x5]
Marty could this be from the float32 patches?
Flags: needinfo?(mrosenberg)
It seems possible.  I'll look into this more today.
Flags: needinfo?(mrosenberg)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to Marty Rosenberg [:mjrosenb] from comment #2)
> It seems possible.  I'll look into this more today.

Any luck here? This is a top orange on trunk at the moment.
Comment hidden (Treeherder Robot)
Maybe a duplicate of bug 1039207, which has a r+ patch that just needs landing.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I guess we can close it now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1039207
You need to log in before you can comment on or make changes to this bug.