[PATCH]Changing a partial selection of text with a paragraph style causes the selection to include the entire text

VERIFIED FIXED in mozilla1.0

Status

()

Core
Selection
P2
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: TucsonTester2, Assigned: Joe Francis)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE+ [adt2] FIXINHAND; need a=)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build ID: 20011004

Changing the paragraph of a partial selection of text with a paragraph style
causes the selection to include the entire text.

Reproducible:  Always

Steps to Reproduce:
1.Open composer
2.Click on the paragraph style drop-down on the toolbar and choose address
3.Type in 5 lines of text
4.Highlight the first 3 lines of the text
5.Click on the paragraph style drop-down on the toolbar and choose body text

Actual Results:
All 5 lines will be highlighted.  This happens with the paragraph, address,
preformat paragraph styles.  This also happens if you outdent part of a blockquote.

Expected Results:
I would expect that the selection would only highlight what I had selected. 
Changing a paragraph style should not add to the selection.

Comment 1

17 years ago
Selection bug.
Assignee: syd → mjudge
Component: Editor: Composer → Selection

Comment 2

17 years ago
Confirmed. (BuildID: 2001100903)

(note: style changed as expected, its only the selection after the change that
is wrong)

Comment 3

17 years ago
I think its related to another selection problem: bug 104240

Comment 4

17 years ago
Confirming on build 2001111203.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
joe's rules code. EDITORBASE, looks like Joe is leaving selection on the whole 
thing.
Assignee: mjudge → jfrancis

Comment 6

16 years ago
forgot to nominate for EDITORBASE.
setting to 1.0.
Whiteboard: EDITORBASE
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 7

16 years ago
if no one can reproduce this on tip i will assume i have fixed it with other
work.  so far this is WFM.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 9

16 years ago
I am still seeing this problem on the 02-13 trunk build on Win ME.  

I am reopening this bug.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 10

16 years ago
ok - i see it on tip.  Earlier comment was with a build that has some patches
that have not yet landed.  I'll try to get this for 099.
Status: REOPENED → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.9
(Assignee)

Comment 11

16 years ago
I'll go ahead and nominate this one.  It's borderline in my book.  
Whiteboard: EDITORBASE → EDITORBASE, nsbeta1

Comment 12

16 years ago
Plussing, behaviour is unexpected and may cause user to get confused.
Retargetting to mozilla 1.0
Keywords: nsbeta1+
Whiteboard: EDITORBASE, nsbeta1 → EDITORBASE+
Target Milestone: mozilla0.9.9 → mozilla1.0
(Assignee)

Comment 13

16 years ago
pri = 2 for original 1.0 EB+ bugs
Priority: -- → P2

Updated

16 years ago
Whiteboard: EDITORBASE+ → EDITORBASE+ [adt2]
(Assignee)

Comment 14

16 years ago
Created attachment 77029 [details] [diff] [review]
patch to nsSelectionState.cpp

fixed a logic error
(Assignee)

Updated

16 years ago
Whiteboard: EDITORBASE+ [adt2] → EDITORBASE+ [adt2] FIXINHAND; need r,sr,a=
Comment on attachment 77029 [details] [diff] [review]
patch to nsSelectionState.cpp

Abzolutely, Herr Vranzis !
r=glazman
Attachment #77029 - Flags: review+

Updated

16 years ago
Summary: Changing a partial selection of text with a paragraph style causes the selection to include the entire text → [PATCH]Changing a partial selection of text with a paragraph style causes the selection to include the entire text

Comment 16

16 years ago
Comment on attachment 77029 [details] [diff] [review]
patch to nsSelectionState.cpp

sr=kin@netscape.com
Attachment #77029 - Flags: superreview+

Updated

16 years ago
Whiteboard: EDITORBASE+ [adt2] FIXINHAND; need r,sr,a= → EDITORBASE+ [adt2] FIXINHAND; need a=
adt1.0.0
Keywords: adt1.0.0, approval

Comment 18

16 years ago
Comment on attachment 77029 [details] [diff] [review]
patch to nsSelectionState.cpp

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #77029 - Flags: approval+

Comment 19

16 years ago
adt1.0.0+ (on ADT's behalf) approval for checkin into 1.0.
Keywords: adt1.0.0 → adt1.0.0+
(Assignee)

Comment 20

16 years ago
fix landed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 21

16 years ago
Tucson, please verify this on latest build...thanks...

Comment 22

16 years ago
Verified on 04-08 trunk.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 23

16 years ago
This landed before branch cut.  Hence: fixed1.0.0
Keywords: approval → fixed1.0.0

Comment 24

16 years ago
Verified 04-19 1.0.0 branch.
Keywords: fixed1.0.0 → verified1.0.0
You need to log in before you can comment on or make changes to this bug.