When the clock alarm goes off while the user is in a call while the device is close to your ears, no alarm beeping sound is heard

RESOLVED DUPLICATE of bug 1038691

Status

RESOLVED DUPLICATE of bug 1038691
4 years ago
4 years ago

People

(Reporter: jsmith, Assigned: scheng)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Reporter)

Description

4 years ago
Breakout of [B] in https://bugzilla.mozilla.org/show_bug.cgi?id=1026167#c73.

STR

1. Set an alarm to go off soon
2. Get onto a phone call with the phone close to your ears
3. Wait for the alarm to go off

Expected

A soft alarm sound should be heard.

Actual

No alarm sound is heard.
(Reporter)

Comment 1

4 years ago
I'm adding qawanted here to see if vibration is felt when this STR executed. If there isn't vibration, then this is likely a problem we need to fix for 2.0, as the user doesn't know that an alarm went off. If there is vibration, then we can probably live with this bug for 2.0.
Keywords: qawanted
(Reporter)

Comment 2

4 years ago
(In reply to Jason Smith [:jsmith] - PTO 7/14 - 7/18 from comment #1)
> I'm adding qawanted here to see if vibration is felt when this STR executed.
> If there isn't vibration, then this is likely a problem we need to fix for
> 2.0, as the user doesn't know that an alarm went off. If there is vibration,
> then we can probably live with this bug for 2.0.

To clarify if there isn't vibration, then we probably need to fix the vibration issue. If we find there isn't vibration, please open a new bug for that.
(Reporter)

Comment 3

4 years ago
(In reply to Jason Smith [:jsmith] - PTO 7/14 - 7/18 from comment #2)
> (In reply to Jason Smith [:jsmith] - PTO 7/14 - 7/18 from comment #1)
> > I'm adding qawanted here to see if vibration is felt when this STR executed.
> > If there isn't vibration, then this is likely a problem we need to fix for
> > 2.0, as the user doesn't know that an alarm went off. If there is vibration,
> > then we can probably live with this bug for 2.0.
> 
> To clarify if there isn't vibration, then we probably need to fix the
> vibration issue. If we find there isn't vibration, please open a new bug for
> that.

fix the vibration issue for 2.0, not the alarm sound*
This bug repro's on: Flame 2.1 Master, Flame 2.0, Flame 1.4 and Buri 2.1

Actual Results: With an alarm set to go off when on a call, if the phone is close to your ear, no audio or vibration is heard or felt when the alarm fires. The only way to tell the alarm is firing is to hang up the call.

Environmental Variables:
Device: Flame Master
Build ID: 20140716065602
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: f6e46d1fc903
Version: 33.0a1 (Master)
Firmware Version: v122
-----------------------------------------------
Environmental Variables:
Device: Flame 2.0
Build ID: 20140716084350
Gaia: 5fa5611fc747d397dbaa2c5ccdc776f1dfd2b6e8
Gecko: 3045ff641a0b
Version: 32.0a2 (2.0)
Firmware Version: v122
-----------------------------------------------
Environmental Variables:
Device: Flame 1.4
Build ID: 20140716073943
Gaia: edec55eb65b4b8be3e44bedab2949f295784dff1
Gecko: 90162ab32776
Version: 30.0 (1.4)
Firmware Version: v122
-----------------------------------------------
Environmental Variables:
Device: Buri Master
Build ID: 20140716065602
Gaia: d29773d2a011825fd77d1c0915a96eb0911417b6
Gecko: f6e46d1fc903
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Need to make a couple corrections here regarding comment 4.

Due to the Broken 2.1 Alarm bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1037079
Affected Flame 2.1 tested build is actually:

Environmental Variables:
Device: Flame Master
Build ID: 20140707224330
Gaia: 1dc9e53393ae4680a174dffa44a958ec564ebbe8
Gecko: c45f6e6d6005
Version: 33.0a1 (Master)
Firmware Version: v122

------------------------------------------------------

Also Buri 2.1 is actually UNAFFECTED after testing with a older build where Alarm wasn't busted.

Actual results: During a Call, vibration AND audio can be heard from the Buri 2.1 for alarms.

Environmental Variables:
Device: Buri Master
Build ID: 20140707224330
Gaia: 1dc9e53393ae4680a174dffa44a958ec564ebbe8
Gecko: c45f6e6d6005
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg


Please let me know if there is confusion here.
Flags: needinfo?(jmitchell)
Flags: needinfo?(jmitchell)
(Assignee)

Updated

4 years ago
Assignee: nobody → scheng
(Assignee)

Comment 6

4 years ago
Waiting for Bug 1038691 is resolved and then check this STR. If there is beeping sounds, this is not a issue.
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Assignee)

Comment 7

4 years ago
(In reply to Star Cheng [:scheng] from comment #6)
> Waiting for Bug 1038691 is resolved and then check this STR. If there is
> beeping sounds, this is not a issue.

I have flashed latest SW on flame device. The behavior fits the comment 0 of this bug. So I mark this bug as duplicate.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1038691
You need to log in before you can comment on or make changes to this bug.