Using "Search Google for" via the context menu doesn't work as expected when highlighting a word within a link

RESOLVED DUPLICATE of bug 985824

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 985824
4 years ago
4 years ago

People

(Reporter: Brian, Unassigned)

Tracking

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8456189 [details]
example.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

1. Select one or more words in a hyperlink on any webpage
2. Right-click the selection to bring up the context menu
3. Left-click "Search Google for "_______"


Actual results:

The Google search results open in a new tab, but the search performed is for the full anchor text of the link, not the selected text.


Expected results:

In previous Firefox versions, the Google search results opened in a new tab with only the selected text as the search. I believe this should be the default behavior.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 985824
You need to log in before you can comment on or make changes to this bug.