Closed Bug 1038815 Opened 6 years ago Closed 6 years ago

Contacts can get into a 'frozen' state in some cases

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.1 S3 (29aug)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: sergi, Assigned: sergi)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

In some cases, for example by pressing the settings button repeatedly, Contacts will go into a blank screen, with the user having to restart the app.
Attached file Github PR (obsolete) —
This patch ensures that Contacts will come back to a valid state even if it freezes up. The patch doesn't do much, mostly because the architecture for subsections will change soon and the code in navigation.js will become obsolete.
Attachment #8456287 - Flags: review?(francisco)
Assignee: nobody → sergi.mansilla
Target Milestone: --- → 2.0 S6 (18july)
Attached patch Actual Github PRSplinter Review
Actual pull request
Attachment #8456287 - Attachment is obsolete: true
Attachment #8456287 - Flags: review?(francisco)
Attachment #8457051 - Flags: review?(francisco)
Comment on attachment 8457051 [details] [diff] [review]
Actual Github PR

Can we create unit tests for this?

I know sometimes we will endup writing more tests than patches, but sure will be helpful in time.
Attachment #8457051 - Flags: review?(francisco)
Of course, no problem.
Target Milestone: 2.0 S6 (18july) → 2.1 S1 (1aug)
Target Milestone: 2.1 S1 (1aug) → 2.1 S2 (15aug)
Target Milestone: 2.1 S2 (15aug) → ---
Duplicate of this bug: 1050515
Carrying over flags from the dupe.
blocking-b2g: --- → 2.0+
Keywords: regression
Comment on attachment 8457051 [details] [diff] [review]
Actual Github PR

We have been speaking offline to land this, since the change is pretty simple and do a follow up with integration tests (we'll need a bit of time to do this tests)
Attachment #8457051 - Flags: review+
Target Milestone: --- → 2.1 S3 (29aug)
We have created bug 1056081 to add integration tests to this use case.
See Also: → 1056081
Merged at 4ccb207518f62baa5160a735a6189d3ba9d34e1d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.