Factor out mozilla::pkix::der::Input into its own header and move it out of the "der::" namespace

RESOLVED FIXED in mozilla33

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: briansmith, Assigned: briansmith)

Tracking

Trunk
mozilla33
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8456306 [details] [diff] [review]
factor-out-Input-Result-etc.patch

I want to be able to pass Input objects to the TrustDomain callbscks instead of passing them less-safe-to-use SECItems. This patch is the first step towards acheiving that. The overall goals are to make TrustDomain implementations safer, and to reduce the use of SECItem (which will happen in future patches).

I'd like to land this before the merge to Aurora so that it will be easier to uplift patches from Nightly 34 to Aurora 33.
Attachment #8456306 - Flags: review?(mmc)
Depends on: 1038828
Comment on attachment 8456306 [details] [diff] [review]
factor-out-Input-Result-etc.patch

Review of attachment 8456306 [details] [diff] [review]:
-----------------------------------------------------------------

LG pending green try.

::: security/pkix/include/pkix/Result.h
@@ +80,5 @@
> +Fail(PRErrorCode errorCode)
> +{
> +  PR_ASSERT(errorCode != 0);
> +  PR_SetError(errorCode, 0);
> +  return MapSECStatus(SECFailure);

Hmm, 2 MapSECStatuses...

Can this be mozilla::pkix::MapSECStatus for clarity?
Attachment #8456306 - Flags: review?(mmc) → review+
Comment on attachment 8456306 [details] [diff] [review]
factor-out-Input-Result-etc.patch

Review of attachment 8456306 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the quick review!

https://hg.mozilla.org/integration/mozilla-inbound/rev/58fe2785ca6a

::: security/pkix/include/pkix/Result.h
@@ +80,5 @@
> +Fail(PRErrorCode errorCode)
> +{
> +  PR_ASSERT(errorCode != 0);
> +  PR_SetError(errorCode, 0);
> +  return MapSECStatus(SECFailure);

I guess you are referring to the other MapSECStatus in ScopedNSSTypes ( nsresult MapSECStatus(SECStatus)), right? OK, I added the qualifier. Though, in my next patchset I remove this code completely.
https://hg.mozilla.org/mozilla-central/rev/58fe2785ca6a
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.