Rename WebGLBuffer::BeenUsedWithMultiple types and cleanup WebGLContextValidate's usage of EnumName

RESOLVED DUPLICATE of bug 1039916

Status

()

RESOLVED DUPLICATE of bug 1039916
4 years ago
4 years ago

People

(Reporter: wlitwinczyk, Assigned: wlitwinczyk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Comment 1

4 years ago
Created attachment 8456414 [details] [diff] [review]
webgl_rename_beenusedwith.patch

Should EnumName be renamed?

Should EnumName return NULL again instead of a default string?
Attachment #8456414 - Flags: feedback?(dglastonbury)
Attachment #8456414 - Flags: feedback?(dglastonbury) → feedback+
(In reply to Walter Litwinczyk [:walter] from comment #1)
> Should EnumName be renamed?
> Should EnumName return NULL again instead of a default string?

I have some ideas from EnumName coming out of the texture work I'm doing. Probably need to ping Jeff to see if my assumptions about reentracy and threading are valid.
(Assignee)

Updated

4 years ago
Depends on: 1039916
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1039916
You need to log in before you can comment on or make changes to this bug.