Site Navigation / Links Toolbar forgets to populate occasionally

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: silvertree, Assigned: jag-mozilla)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011009
BuildID:    2001100903

Basically, I've been using the SNT for browsing through the 'bugs posted today'
list on Bugzilla.  It works most of the time, but every ten bugs or so it
doesn't catch the <link> references in the HTML and just sits there, all options
greyed out.  A reload of the page fixes it, but it'll screw up again some other
number of bugs browsed.  The page has finished loading, at least according to
the throbber and 'Document: Done' at the bottom.

Reproducible: Sometimes
Steps to Reproduce:
1. Do a decent-sized query on bugzilla.
2. Start to scroll through the bugs via the SNT.


Actual Results:  Every once in a while, all of the buttons on the Site
Navigation Toolbar will grey themselves out, despite the fact that the page has
all of the proper links.

Expected Results:  It should always have /some/ active buttons.

At least, I hope so; I'd say that Bugzilla is forgetting to put the <links>, but
the toolbar is displayed on 'Only When Needed', so I assume they're really
there.  Next time it occurs I'll look at the page source and make sure that the
<link> elements are really there.
(Reporter)

Comment 1

17 years ago
Created attachment 52763 [details]
Screenshot showing unusable SNT; took very little time to duplicate.
Dependencies n' so forth...I'll be on the lookout for this.
Assignee: asa → blakeross
Blocks: 103053
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → claudius

Comment 3

17 years ago
Was able to reproduce this on first try with the "Bugs reported today" bugzilla
list.  Am using build 2001101221 Linux.  The JavaScript console shows no errors,
so no clues there.  I'd confirm this bug if I could.

There's a good chance this bug will magically go away after the toolbar gets
XBL'ified.  Recommending we FUTURE this bug and wait to see if my prediction is
right.

Can someone with sufficient power CONFIRM this bug and also update the URL to
the "Bugs reported today" URL available on the Bugzilla homepage?

Comment 4

17 years ago
Came across this bug while browsing they new ones, too. I have SNB in "show only
when needed" mode and with one of the bugs it didn't show up. reloading the
pages solved it. not extremly sever bug, IMHO.
2001101608, redhat

Comment 5

17 years ago
--> sballard
Assignee: blakeross → sballard
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
Odd that this bug should have survived the fix for bug 103097, really.

I'll keep an eye out for it too and see if I can figure out what's going on.
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
Assignee: sballard → jag
QA Contact: claudius

Comment 7

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 8

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.