font switches between SansSerif & TimesRoman styles when reloading the page after editing the file on the server

RESOLVED WORKSFORME

Status

()

Core
Layout
--
minor
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Gregory P. Smith, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla1.1alpha
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091311

While editing my homepage on the server I reload it in mozilla to see the
changes.  I noticed that after I edit the file and save it and hit reload in
mozilla (electricrain.com is a remote machine) that the font used to render the
text shows up in a sans serif face.  if i hit reload again, it reverts to the
default Times style.  Repeated reloads keep it in times unless i touch the file
on the server.  when i do that it reverts to sans serif for that reload agian.

[the specific edit i made after i noticed this was to add the surrounding table
with the lard council ad on the left, it may have happened before but i didn't
notice]


Reproducible: Always
Steps to Reproduce:
1. see description
2.
3.

Actual Results:  see description

Expected Results:  been consistent with respect to the font it uses.
Gregory, could you please retest with a recent nightly?  There've been a few
history/cache bugs fixed since 0.9.4 that could be causing this....

(I can't reproduce this bug with a copy of that page that I saved and loaded
from my local server)
(Reporter)

Comment 2

16 years ago
Okay, i just downloaded Mozilla Build ID 2001100902 and reverified this bug.  It
still happens.  All I have to do on the server end is to hit ":w" in vi to save
the file (even without any changes) and the next mozilla reload of the page uses
sans instead of times.  [note the font tags within the page, i wonder if the
/font tag for the sans in the google search box is being lost/ignored of the time?]

Comment 3

16 years ago
I see the bug on a current linux CVS build.

On first load from web, the page lays out with Arial.
On a reload the font changes to Times
On a shift+reload the font again changes to Arial

It should seemingly be using Times all along, apart from the top sentence (a
name) where font is arial, helvetica, courier. That tag is properly closed, so
the rest of the page ought to fall back to Times from there..

Comment 4

16 years ago
sorry - weird bug - i also saw it the other way around; shift+reload will show
Times. I may be colliding with reporters new uploads here..
layout
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 6

16 years ago
please the environment variable NS_FONT_DEBUG=5, do a minimal run 
(eg: ./mozilla http://some.website.com/some_content.html), capture the output,
and attach it to this bug
(Reporter)

Comment 7

16 years ago
i will try your FONT_DEBUG suggestion later tonight when it am at the machine i
reported this bug on.

I just noticed, however, that on a different machine running build 2001101608
that I can't get the behavior to happen.  I'll reverify the behavior on the
original machine later.
(Reporter)

Comment 8

16 years ago
Created attachment 54193 [details]
NS_FONT_DEBUG=5 was set when running.  {Build ID: 2001101202}
(Reporter)

Comment 9

16 years ago
I have attached the NS_FONT_DEBUG=5 output.

the sequence in mozilla was:

1) run mozilla, it loads my homepage.
2) click on the link to http://electricrain.com/greg/
3) hit reload and/or shift-reload a few times.

The -difference- i notice now is that there seems to be no relation to the file
timestamp on the web server [perhaps it wasn't there in the first place?  or was
just a coincidental timing issue?].  seemingly randomly, some of the times that
i reload the page i get the Sans style font instead of Times.  very strange.

It doesn't happen often and I've never conciously noticed any font issues during
normal browsing so i'd rate this low priority.

Comment 10

16 years ago
Gregory: is it possible to get a minimal case where it succeeded and where it
failed so I can compare them? (eg: without several shift-reloads)

Updated

16 years ago
Target Milestone: --- → mozilla1.1
No response for over a year; resolving WFM. Please reopen the bug if you can
provide the information requested in comment #10. Thanks.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.