[MTCS][fxos-certsuite-1.3.0.9] SMS Incoming/outgoing and Telephony Incoming/outing keep failing

RESOLVED FIXED

Status

Firefox OS
Certification Suite
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: vchen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8456755 [details]
firefox-os-certification_20140716151353.zip

Running the MCTS v1.3.0.9 with Mac OS and python 2.7.6. In the Conformance Test part, the SMS Incoming/Outgoing part is always fail even if the tester follow the instruction on the screen.

As to the telephony incoming/outing test, it just fail...we don't see any incoming/outgoing call activities at all

Attached please find the logs
Flags: needinfo?(jgriffin)
Rob, can you take a look and see if you can reproduce this?
Flags: needinfo?(jgriffin) → needinfo?(rwood)
Blocks: 970615

Comment 2

4 years ago
I ran the semi-auto webapi tests on hamachi with the latest 1.3 build.

The webapi SMS tests all passed.

The webapi telephony tests fail on 1.3, because disabling the default dialer agent is broken in 1.3 (known issue).

Unfortunately the webapi_structured.log file is missing from the attached results.zip (looks like there was a mozlog error for some reason), therefore no logs for the semiauto webapi tests were provided. Therefore I am unable to verify that the telephony tests failed for the same reason (dialer agent), and there is no insight into the SMS failures.

Please try running the tests again and see if you can get a webapi_structured.log file; if not if you could take a screenshot of the browser test runner itself while the SMS and Telephony webapi test results/failures are displayed, that would be really helpful. Thanks!
Flags: needinfo?(rwood)
Note that MCTS 1.3.0.10 has been released and may provide better logging in case of failure.
(In reply to Robert Wood [:rwood] from comment #2)
> I ran the semi-auto webapi tests on hamachi with the latest 1.3 build.
> 
> The webapi SMS tests all passed.
> 
> The webapi telephony tests fail on 1.3, because disabling the default dialer
> agent is broken in 1.3 (known issue).
> 
Should we disable telephony tests on 1.3 then?
Flags: needinfo?(rwood)

Comment 5

4 years ago
They run fine on 1.3T on tarako though (I'm guessing they back-ported the new callscreen there but not to 1.3).
Flags: needinfo?(rwood)
We've added code to disable the Telephony tests on devices where we can't disable the dialer agent (a necessary pre-requisite to running the tests).  The SMS tests seem to work fine with the latest release, so closing this; please re-open if needed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.