Closed Bug 1039464 Opened 6 years ago Closed 6 years ago

Output in the browser/web console has the wrong ordering

Categories

(DevTools :: Console, defect)

31 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 755555

People

(Reporter: sworddragon2, Unassigned)

Details

Attachments

(1 file)

372 bytes, application/xhtml+xml
Details
Attached file index.xhtml
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140702123034

Steps to reproduce:

1. Open the testcase in the attachments.
2. Open the browser or web console and look at the output.


Actual results:

The output is:

ReferenceError: assignment to undeclared variable tmp index.xhtml:11
"test1" index.xhtml:10
"test2" index.xhtml:12


Expected results:

The output should be:

"test1" index.xhtml:10
ReferenceError: assignment to undeclared variable tmp index.xhtml:11
"test2" index.xhtml:12
Component: Untriaged → Developer Tools: Console
Thanks for the bug report.

This is happening because our console API store is populated and processed async. The same goes with script errors and warnings, but they are processed in a separate place. The fix would be to reorder messages within the console output.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755555
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.