[Messages][Refactoring] Implement EventDispatcher object

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::SMS
--
minor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: azasypkin, Assigned: azasypkin)

Tracking

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: [sms-sprint-2.0S6])

Attachments

(1 attachment)

EventDispatcher object will help us to replace direct dependcies between components with publish/subscribe pattern.
(Assignee)

Comment 1

4 years ago
Created attachment 8456983 [details] [review]
GitHub pull request URL

Hey Julien,

Here is EventDispatcher that we have been discussing recently.

Thanks
Attachment #8456983 - Flags: review?(felash)
Comment on attachment 8456983 [details] [review]
GitHub pull request URL

looks good, let's do another round for the comments I made :)
Attachment #8456983 - Flags: review?(felash)
(Assignee)

Comment 3

4 years ago
Comment on attachment 8456983 [details] [review]
GitHub pull request URL

(In reply to Julien Wajsberg [:julienw] from comment #2)
> Comment on attachment 8456983 [details] [review]
> GitHub pull request URL
> 
> looks good, let's do another round for the comments I made :)

Added second commit with suggested changes, thanks!
Attachment #8456983 - Flags: review?(felash)
(Assignee)

Updated

4 years ago
Blocks: 1035283
Whiteboard: [not-part-of-initial-sprint]
Comment on attachment 8456983 [details] [review]
GitHub pull request URL

r=me with a green travis or gaia try
Attachment #8456983 - Flags: review?(felash) → review+
(Assignee)

Comment 5

4 years ago
(In reply to Julien Wajsberg [:julienw] from comment #4)
> Comment on attachment 8456983 [details] [review]
> GitHub pull request URL
> 
> r=me with a green travis or gaia try

Thanks for review!

Master: https://github.com/mozilla-b2g/gaia/commit/28911d958fc86d638a104923f9e39003fbcf080c
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Blocks: 1041124
Blocks: 944249
No longer blocks: 1035283
Whiteboard: [not-part-of-initial-sprint] → [sms-sprint-2.0S6]
Comment on attachment 8456983 [details] [review]
GitHub pull request URL

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: -
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low, the new code is not used anywhere yet
[String changes made]: none

We plan to use this new code in some 2.0+ blockers (especially some dependencies of bug 1038176)
Attachment #8456983 - Flags: approval-gaia-v2.0?(lmandel)
(In reply to Julien Wajsberg [:julienw] from comment #6)

> [Testing completed]: yes

Especially this file is heavily unit tested.
Comment on attachment 8456983 [details] [review]
GitHub pull request URL

Making an exception on approving a non 2.0+ bug this time given the risk is manageable and this is going to help critical blockers..

please back this out if there are any fallouts.
Attachment #8456983 - Flags: approval-gaia-v2.0?(lmandel) → approval-gaia-v2.0+
v2.0: https://github.com/mozilla-b2g/gaia/commit/28a8c9a11fcdac3f5709c3eef2b861bbe01cd464
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S6 (18july)
Blocks: 1041967
You need to log in before you can comment on or make changes to this bug.