Show total time spent completing a task

RESOLVED DUPLICATE of bug 1030767

Status

P4
normal
RESOLVED DUPLICATE of bug 1030767
5 years ago
2 months ago

People

(Reporter: rbillings, Unassigned)

Tracking

Version 2
Milestone 2
x86
Mac OS X

Details

(Reporter)

Description

5 years ago
Currently the admin system collects the start and end/abandon times for tasks as separate events. There is interest in displaying the total time taken for the task.
We capture when the attempt was created (which is the start time) and when it was last modified (which would be the finish time for a completed task). Is this just about displaying both of those times in the admin screen, as well as a column showing the difference between those two times?
(Reporter)

Comment 2

5 years ago
Yes, there is interest in showing the difference between the start/end as a separate piece of data. You can manually figure it out, but as the list of start/end/abandon lines are not always displayed together it has become annoying enough to become a request.
I'm confused. I only see the Modified date in the admin, I don't see the created date at all. Which screen are you looking at where you can see both at the same time? At https://oneanddone.paas.allizom.org/admin/tasks/taskattempt/ there is only one record per task attempt, there are not multiple records per attempt.
(Reporter)

Comment 4

5 years ago
Total time = difference between Modified date + Started State and Modified date + Finished or Abandoned State
I think you are misinterpreting the screen, or I am misunderstanding you. There is only one row per attempt. If an attempt is started a record is created. When that attempt is abandoned or finished, the same record is updated. When I look at https://oneanddone.paas.allizom.org/admin/tasks/taskattempt/ all I can see is the Modified date, so I'm not sure what two dates you are using to manually calculate the difference.
(Reporter)

Comment 6

5 years ago
I did not realize that there was only one record per attempt. I thought there was one for start and one for completion, as opposed to last time modified. 

Evidently this request includes saving the start time, in order to calculate the time it takes to complete the task. Since it doesn't do that currently, the complexity of this request just got higher.
Actually, it didn't. The start time will always be the creation time for the attempt, and the finish time will be the Modified time, so we have both things already.
I believe that this has now become a dupe of Bug 1030767, as that screen will show this "time to complete" for a task attempt. I'm going to mark this as a dupe, but feel free to reopen if I am mistaken.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1030767

Updated

2 months ago
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.