Don't display the "you can vouch this profile" message if user.can_vouch is False

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
--
blocker
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mbrandt, Assigned: giorgos)

Tracking

2014-07.3

Details

(Whiteboard: [vouching rel. 1] , URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8457048 [details]
qa - screenshot of bug on dev

Upon visiting a Mozillian profile that is unvouched, the form to vouch for that profile does not exist.

Steps to reproduce:
0. With a vouched account goto an unvouched profile [https://mozillians-dev.allizom.org/u/xavierthemightytuna/]
1. vouch for the profile

Expected:
A form is present that allows vouching of that account

Actual:
The message "This profile is waiting for approval. If you would like to vouch for them, use the form at the bottom of the page" is present however the form is not.
(Reporter)

Updated

4 years ago
Summary: [dev] The ability to vouch for a new Moz → [dev] The ability to vouch for a new Mozillian is broken
(Assignee)

Comment 1

4 years ago
The bug is that you see that message, not that you don't see the form. Your account on -dev cannot vouch, because you only have 1 vouch and >= 3 vouches (see also https://bugzilla.mozilla.org/show_bug.cgi?id=1033993#c9 for more details)
Summary: [dev] The ability to vouch for a new Mozillian is broken → Don't display the "you can vouch this profile" message if user.can_vouch is False
(Assignee)

Updated

4 years ago
Assignee: nobody → giorgos
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
(In reply to Giorgos Logiotatidis [:giorgos] from comment #1)
> Your account on -dev cannot vouch, because you only have 1 vouch and >= 3 vouches

Your account on -dev cannot vouch, because you only have 1 vouch and _not_ >= 3 vouches

Comment 3

4 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/7627aed416109d6dbccda530dd173470b08bbaef
[fix bug 1039652] Don't display vouch message message if user.can_vouch is False.

https://github.com/mozilla/mozillians/commit/9b9bebe11eb833b1cbe383f0a7350f2e219bcb2b
Merge pull request #1044 from glogiotatidis/1039652

[fix bug 1039652] Don't display vouch message message if user.can_vouch is False.

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Version: other → next
QA verified. If account on -dev has only have 1 vouch and _not_ >= 3 vouches it cannot vouch.
3+ vouches allow you to vouch
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Version: next → 2014-07.3
You need to log in before you can comment on or make changes to this bug.