htmlguru.com - Only the background loads up

RESOLVED FIXED

Status

P3
major
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: decibel8, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
I was lead to this page by someone. I only got the background. No errors,
warnings come up about not having a plug-in present,...
They said to try it in Internet Explorer. I did and loaded right up with all the
stuff the guru put on there. Pretty neat. Too bad it doesn't work in Mozilla.
Works fine in Netscape on Linux.
Mozilla builds: 2001092020 and 201100116

Comment 1

17 years ago
Seems to be the javascript. Send the "guru" a note to fix it.

onLoad="
    if(is.ns4) {
        available_width=innerWidth;
        available_height=innerHeight;
        document.onkeydown = keyDown;
        document.captureEvents(Event.KEYDOWN);
        choreographer('layerSetup',null);
    } else if(is.ie4 || is.ie5) {
        available_width=document.body.clientWidth;
        available_height=document.body.clientHeight;
        document.onkeydown = keyDown;
        choreographer('layerSetup',null);
    }"

Bad programming practice. No "else" clause.
(Reporter)

Comment 2

17 years ago
Done. Wrote him a email describing the problem and where you said the problem was.

Comment 3

17 years ago
Confirmed the reported problem with 11/7/2001 Win32 build.
Change it to assigned.
Thanks, Marcus and David.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 4

16 years ago
The guru must be oxygen-deprived from too much time on a mountaintop. Still broken.

Error: starLyr has no properties
Source File: http://www.htmlguru.com/guru.js
Line: 80
Severity: normal → major
OS: Linux → All
Priority: -- → P3
Hardware: PC → All
Summary: Only the background loads up. This page works great in Internet Explorer → htmlguru.com - Only the background loads up

Comment 5

16 years ago
-> other
Assignee: momoi → other
Status: ASSIGNED → NEW
Component: The Americas → Other
QA Contact: jonrubin → other
Now when you enter http://www.htmlguru.com/ you can see a message about "the
next version of this site [that] is being built upon full DOM, HTML, CSS and XML
standards set forth by the W3".

Seems they're going to redesign it.
domain is owned by domain grabber
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.