Closed Bug 10397 Opened 21 years ago Closed 21 years ago

setTimeout function does not get called if javascript is not inline.

Categories

(Core :: XUL, defect, P2, major)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: gayatrib, Assigned: vidur)

Details

If javascript is included in a separate .js file, the setTimeout function does
not get activated, causing the onload handler not to be called. As the onload
handleris not working by itself yet, I need to use the setTimeout function to
invoke it. If javascript is inline, this works ok.
Priority: P3 → P2
Changing to P2 because this is preventing us from meeting Tao's guidelines for
I18N of XUL files.
Assignee: trudelle → vidur
This works for me now.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
If it works I'm closing the bug?

Also, please provide a test case for any bugs that you post. Unless the issue is
obvious, it's not always possible for me (or the QA contact) to create a test
case.
Status: RESOLVED → VERIFIED
I'm marking this bug as verified as of 19990730 builds.
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: ckritzer → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.